Publisher Role
Table of Contents

Table of Contents .................................................................................................................. 2

Preface .................................................................................................................................. 6

The Purpose of This Training ......................................................................................... 6
Target Audience .................................................................................................................. 6
Instructor-led Exercise ......................................................................................................... 6
Training datasets ................................................................................................................ 6
How to Use This Training ................................................................................................. 6
Icons to Look For ............................................................................................................... 6

Module 1: Introduction to Tableau .................................................................................. 7

Module Objectives ............................................................................................................ 7
Tableau Overview ............................................................................................................... 7
  Choose the Right Tool .................................................................................................... 8
  Tableau Development Process ................................................................................... 9
Opening Tableau through Care Connect ....................................................................... 9
Workbooks and Sheets ..................................................................................................... 11
High-Level Concepts and Terminology of Tableau Workbook ..................................... 12
  Add a Worksheet or Dashboard .................................................................................. 13
  Delete a Worksheet ..................................................................................................... 13
  Hiding and Showing Worksheets ................................................................................ 13
UCLA Templates ............................................................................................................... 14
Module Summary ............................................................................................................. 15

Module 2: Connect to Data .............................................................................................. 16

Module Objectives ............................................................................................................ 16
Overview ........................................................................................................................... 16
Data Connection Process ............................................................................................... 17
Data Connection Types .................................................................................................... 18
Database Connection Options ........................................................................................ 19
Connect to Sample Excel Data ....................................................................................... 20
  Creating an Extract .................................................................................................... 22
  Remove an Extract ...................................................................................................... 24
Module Summary ............................................................................................................. 24

Module 3: Managing Data: Filtering, Sorting, Grouping, and Sets ............................... 25

Module Objectives ............................................................................................................ 25
Filters ................................................................................................................................. 25
  Adding Filters ............................................................................................................... 25
Quick Filters ..................................................................................................................... 27
  Add Quick Filter .......................................................................................................... 27
  Customizing Quick Filters ......................................................................................... 29
Global Filter ...................................................................................................................... 30
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Global Filter</td>
<td>30</td>
</tr>
<tr>
<td>Make Global Filter Local</td>
<td>30</td>
</tr>
<tr>
<td>Context Filters</td>
<td>30</td>
</tr>
<tr>
<td>Create Context Filters</td>
<td>31</td>
</tr>
<tr>
<td>Sorting, Groups, and Sets Defined</td>
<td>31</td>
</tr>
<tr>
<td>Sorting</td>
<td>31</td>
</tr>
<tr>
<td>Apply Computed Sorting</td>
<td>32</td>
</tr>
<tr>
<td>Manual Sort Using the Toolbar</td>
<td>34</td>
</tr>
<tr>
<td>Manual Sort by Drag and Drop</td>
<td>34</td>
</tr>
<tr>
<td>Default Sort</td>
<td>34</td>
</tr>
<tr>
<td>Clear Sort</td>
<td>35</td>
</tr>
<tr>
<td>Grouping</td>
<td>35</td>
</tr>
<tr>
<td>Create a Group</td>
<td>35</td>
</tr>
<tr>
<td>Edit Group</td>
<td>37</td>
</tr>
<tr>
<td>Create a Group by Selecting Marks</td>
<td>37</td>
</tr>
<tr>
<td>Remove Group</td>
<td>38</td>
</tr>
<tr>
<td>Sets</td>
<td>38</td>
</tr>
<tr>
<td>Create a Set by Selecting Marks</td>
<td>39</td>
</tr>
<tr>
<td>Create a Set from a Field</td>
<td>42</td>
</tr>
<tr>
<td>Copy Crosstab/Data/Image from View</td>
<td>43</td>
</tr>
<tr>
<td>Copy and Paste Information Between Workbooks</td>
<td>46</td>
</tr>
<tr>
<td>Module Summary</td>
<td>48</td>
</tr>
</tbody>
</table>

**Module 4: Building Views** ........................................................................ 49

<table>
<thead>
<tr>
<th>Subsection</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Module Objectives</td>
<td>49</td>
</tr>
<tr>
<td>The Tableau Workspace</td>
<td>49</td>
</tr>
<tr>
<td>Data Connection Window</td>
<td>50</td>
</tr>
<tr>
<td>Toolbar</td>
<td>50</td>
</tr>
<tr>
<td>Dimensions and Measures Fields</td>
<td>51</td>
</tr>
<tr>
<td>Change Measure to Dimension</td>
<td>53</td>
</tr>
<tr>
<td>Rename Fields</td>
<td>53</td>
</tr>
<tr>
<td>Adding a Comment to a Field</td>
<td>53</td>
</tr>
<tr>
<td>Adding Aliases</td>
<td>54</td>
</tr>
<tr>
<td>Hierarchies</td>
<td>54</td>
</tr>
<tr>
<td>Using Hierarchies in Shelves</td>
<td>55</td>
</tr>
<tr>
<td>Creating a Hierarchy</td>
<td>55</td>
</tr>
<tr>
<td>Folders</td>
<td>56</td>
</tr>
<tr>
<td>Creating a Folder</td>
<td>56</td>
</tr>
<tr>
<td>Building a Tableau View</td>
<td>56</td>
</tr>
<tr>
<td>Working with Text Tables (Cross-tab)</td>
<td>57</td>
</tr>
<tr>
<td>Keep Only, Exclude, or Hide</td>
<td>58</td>
</tr>
<tr>
<td>Working with Cards and Shelves</td>
<td>59</td>
</tr>
<tr>
<td>Rearranging Cards</td>
<td>59</td>
</tr>
<tr>
<td>Types of Shelves</td>
<td>60</td>
</tr>
<tr>
<td>Columns and Rows Shelves</td>
<td>60</td>
</tr>
<tr>
<td>Pages Shelf</td>
<td>61</td>
</tr>
<tr>
<td>Filters Shelf</td>
<td>61</td>
</tr>
<tr>
<td>Detail on Marks Card</td>
<td>61</td>
</tr>
<tr>
<td>Color Shelf</td>
<td>62</td>
</tr>
</tbody>
</table>
Module Objectives

Module 6: Table Calculations ................................................................. 77

Module Objectives ....................................................................... 77
Table Calculations Overview ...................................................... 77
Addressing and Partitioning Table Calculations rely on two types of fields: addressing and partitioning fields. The key to understanding Table Calculations is to know how these fields work. 77
Quick Table Calculations ............................................................. 79
Adding a running total quick calculation ..................................... 79
Adding a Ranking Quick Calculation ........................................... 81
Module Summary ........................................................................ 82

Module 7: View Enhancements: Formatting, Annotations, and Labels ............... 83

Module Objectives ....................................................................... 83
Formatting Worksheet ................................................................ 83
Opening the Format Window .................................................... 83
Font Setting ................................................................................. 84
Alignment .................................................................................... 84
Shading ....................................................................................... 85
Borders...........................................................................................................................................86
Lines................................................................................................................................................87
Format Specific Setting......................................................................................................................87
Numbers.............................................................................................................................................88
Field Labels.........................................................................................................................................89
Legends.............................................................................................................................................89
Add View Title................................................................................................................................90
Add View Caption ............................................................................................................................90
Resize Tables .....................................................................................................................................91
  Resizing Entire Table......................................................................................................................91
  Resizing Rows and Columns ...........................................................................................................91
  Resizing Cells .................................................................................................................................91
Edit Axes.............................................................................................................................................92
  Changing Axis Range.....................................................................................................................92
  Changing Axis Title and Scale ......................................................................................................93
  Modifying Tick Marks....................................................................................................................93
Copy Formatting to Other Worksheets .............................................................................................93
Drop Lines ..........................................................................................................................................94
  Add Drop Line ...............................................................................................................................94
Highlight Marks ..............................................................................................................................95
  Highlight using Color Legend .......................................................................................................95
Annotations.........................................................................................................................................96
  Add a Mark Annotation ................................................................................................................96
  Positioning a Mark Annotation ......................................................................................................97
  Area Annotation ............................................................................................................................97
  Format Annotations .......................................................................................................................97
  Removing Annotations ................................................................................................................97
Labels................................................................................................................................................97
  Displaying Labels for the Entire Worksheet ................................................................................97
  Showing and Hiding Individual Mark Labels .................................................................................97
  Moving Labels ...............................................................................................................................98
Tooltip................................................................................................................................................98
  Add Tooltip ...................................................................................................................................98
Module Summary ..............................................................................................................................100
Preface

The Purpose of This Training

This user guide is for Tableau Desktop. It provides step-by-step instructions to create analytical and interactive reports and dashboards. The user guide gives you an overview of Tableau concepts as applied through a visualization exercise example.

Target Audience

The user guide primarily targets people who will be creating and publishing dashboards to Tableau Server.

Instructor-led Exercise

The instructions in the modules within this user guide are based on the in-class demonstration the instructor will walk-through. Steps should be used as a guideline and may vary once you have access and connection to the production environment post-training.

Training datasets

The examples in this user guide will utilize the following dataset:

1. Sample - Superstore (which we will be connected to through Tableau Server)

How to Use This Training

You can use this user guide in several ways. You can start at the beginning and go module-by-module as you learn the different topics within Tableau. You can also use this user guide as a reference by using the table of contents to jump to particular topics.

Icons to Look For

The following are specific icons to look for when reading:

Tip: The tip gives additional detailed information about a topic.

Note: The note denotes a caution about an aspect of the topic. It will not always be applicable to all situations; you should check whether it applies to you.
Module 1: Introduction to Tableau

Module Objectives

- Understand what Tableau is and identify the Tableau view development process
- Identify standard Tableau roles and permission levels
- Recognize Tableau high-level concepts and terminology
- Learn how to open Tableau and identify the various components of the Tableau Workspace

Tableau Overview

Tableau Desktop is a data visualization software that allows for instantaneous insight by transforming data into visually appealing, interactive visualizations called dashboards. Tableau was designed to process and analyze nearly any data source in a logical, easy to follow manner. This results in far less development time, making your data actionable faster. Once connected to a data source, you can build, query, display, analyze, filter, sort, group, drill down, drill up, calculate, organize, summarize, and present data in a variety of ways. You can then share your visuals with your colleagues through dashboards using Tableau Server. Please note since Tableau is a visualization tool, there may be other reporting tools more appropriate for your needs.
Choose the Right Tool

Please refer to the “Choose the Right Tool” document when deciding when it is suitable to use Tableau.
Tableau Development Process

When you are beginning to develop your workbook and data sources, it is best to plan out prior to development. Use the OHIA Tableau Workbook Designer to help you with this process.

Opening Tableau through Care Connect

In order to open up Tableau Desktop, you will need to have Duo installed on your mobile device.

1. Go to UCLA MedNet homepage
2. From the Business Systems section click Care Connect Local. If you are off campus and not connected to VPN, click Care Connect Remote.
3. Enter your AD Username and Password.
4. Double-click on the OHIA Tableau Desktop icon.
5. You should get a notification on the phone enrolled in DUO. Click on it and the Login Request push notification will pop up. Click Approve.
a. If no notification shows automatically, your notifications from DUO Mobile might be disabled. Click into the DUO Mobile App and click the **Tap to Respond** green bar to get the **Login Request** screen.

![DUO Mobile App](image1)

6. Click the **Tableau icon** on the OHIA Tableau Desktop to launch.

![Tableau 9.0](image2)

The Tableau Start Page opens. The Start Page is organized into three sections:

- **Connect** - The data section lets you either connect to a new data source or quickly open a saved connection. By default, a few sample data source connections are available. As you continue to create and save connections they’ll be added to the list. Sample data sources are also stored here.

- **Open** - The workbooks section shows thumbnail images for workbooks you’ve recently opened. When you open Tableau for the first time, the workbooks section will be blank. As you create and save new workbooks, the 21 most recently used ones are available on the start page. Click a thumbnail image to open the workbook.

- **Samples** - The samples section contains several sample workbooks that show off the kinds of analysis you can do with Tableau.

- **Discover** – The discover section provides links to Tableau training, the latest from the tableau “Viz of the day” and Tableau resources.
Workbooks and Sheets

Workbooks and worksheets within Tableau have a similar structure as Microsoft Excel.

- A workbook can contain multiple worksheets, and each worksheet can be connected to a different data source.
- A worksheet contains a particular view or dashboard of your data. This is where you build views of your data by dragging and dropping fields onto shelves.
  - A dashboard is a combination of several views of data that you can arrange for presentation or to monitor.
  - The sheets, whether worksheets or dashboards, display along the bottom of the workbook as tabs.
# High-Level Concepts and Terminology of Tableau Workbook

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>View / Data View</strong></td>
<td>A visual representation of your data in a table or chart.</td>
<td>N/A</td>
</tr>
<tr>
<td><strong>Worksheet</strong></td>
<td>Worksheets hold your data views.</td>
<td>N/A</td>
</tr>
<tr>
<td><strong>Dashboard</strong></td>
<td>Collection of several worksheets within view in a single composite layout.</td>
<td>N/A</td>
</tr>
<tr>
<td><strong>Workbook</strong></td>
<td>Workbooks hold one or more worksheets and/or dashboards in a single file.</td>
<td>N/A</td>
</tr>
</tbody>
</table>
| **Dimension**         | A dimension is a discrete, descriptive attribute of your data used to define the focus of your analysis. Dimensions cannot be aggregated. | • Category  
• State  
• Date |
| **Measure**           | Measures are quantitative fields that are calculated based upon the specified dimensions. | • Sales  
• Profit  
• Quantity |
| **Cards**             | Cards are containers for shelves, legends, and other controls.            | ▪ Pages  
▪ Filters  
▪ Marks |
| **Shelves**           | Every worksheet in Tableau contains *shelves*. By placing fields on shelves, you can create the rows and columns of a data view, exclude data from the view, show additional levels of detail, and encode the data in various ways. | • Size  
• Shape  
• Level of Detail |
| **Data Connection /** | From here you can view and edit the data source being used. By clicking the Data Source tab on the lower right you can | N/A      |
Add a Worksheet or Dashboard

To add a worksheet, either go to File > New or click on a new tab at the bottom of the window.

To add a dashboard, either go to File > New or click on a new tab at the bottom of the window.

Delete a Worksheet

To delete a worksheet, right-click on a worksheet and select Delete Sheet.

Hiding and Showing Worksheets

A worksheet that is used in a dashboard cannot be deleted, but it can be hidden. Much like Excel, you can hide the worksheets that are used in a dashboard by right-clicking the worksheet tab and selecting Hide Sheet.
Note: Keep in mind that someone viewing the dashboard can still access the hidden worksheet.

You can show a hidden sheet by navigating to the dashboard that uses it. Select Go to Sheet on the dashboard view menu. The hidden sheet is shown temporarily next to the dashboard. When you navigate away from the hidden sheet, it is hidden again. Right-click the sheet tab of the hidden sheet and select Unhide to unhide it permanently.

UCLA Templates

Every time you create a dashboard, you want to keep consistency in formatting, so we've created two templates for you to utilize when creating your dashboards, UCLA Health, and OHIA. These will be found in the Save folder on Citrix, but they can currently be viewed and opened on the Training Tableau Server.

1. Open up Tableau Desktop and go to Server > Open Workbook.

2. You may be prompted to sign into the server: http://bsdtableau02
3. Use your AD credentials to sign in.
4. Open up the UCLA Tableau Templates and you should see the below two dashboards.
Module Summary

You should now be able to:

- Understand what Tableau is and identify the Tableau view development process
- Identify Tableau roles and permission levels
- Recognize Tableau high-level concepts and terminology
- Learn how to open Tableau and identify the various components of the Tableau Workspace
Module 2: Connect to Data

Module Objectives

- Understand difference between live connection and extracts
- See how to connect to a database
- Connect to sample Excel datasets
- Learn to create and remove a data extract

Overview

The first step in the Tableau development process is connecting to data. This step involves connecting to the sample datasets, the respective table(s), and then either connecting live or importing the data from the specified table(s) to be used while creating the dashboard. When you import all or some of your data into the Tableau’s data engine, you create a data extract. The extract can improve performance to enable more advanced capabilities and allow you to do offline analysis.

On the initial startup screen, select the Connect to Data option.
**Data Connection Process**

Follow the below process to decide which type of data connection to use:

*Structure still being defined – locations will be TBD*

When connecting to a data source, first you need to be aware of what type of data source you are connecting to. There are two types of data sources you will be connecting to:

<table>
<thead>
<tr>
<th>Data Source Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>xDR</td>
<td>xDR data sources are any data marts or anything else you have backend access to that is OHIA owned (data marts, Clarity, Cogito etc).</td>
</tr>
<tr>
<td>Non-xDR</td>
<td>Non-xDR will be all other data sources that will be imported as flat files.</td>
</tr>
</tbody>
</table>

If you are connecting to an xDR data source, connect to the data source through Tableau Server. If your data source has yet to be published there, please fill out the request form for this to be completed. If you are still in need of your data mart to be created, contact OHIA-PMO.

Any other data source will be considered a non-xDR data source. In order to connect to these, you need to create a Flat File and go through the Drop Off File Share. This file share is only a one-way into the Citrix Environment. Once you drop off your data source, it will show up on your Citrix Environment in the Drop Off Folder. This will be available for all of the content creators in your CoE to connect to.

In this file share, there will be Master subfolder created. Any data sources that you want shared with your CoE, have been vetted and are your “one source of truth”, place these here. Eventually, these master data sources will be published, allowing you to connect directly through Tableau Server. The Adhoc subfolder will be used for your own data analysis.
Tableau

**Data Connection Types**

Through the Data Connection window, there are three options to create a data connection or impact data for use while creating the dashboard.

- **Connect Live** – select **Live** under connection
- **Import all data** – Select **Extract** under connection
- **Import some data** – Select **Extract** under connection and then select **Edit** and choose to import N top rows or **Add** under Filters to add data filters

<table>
<thead>
<tr>
<th>Data Connection Option</th>
<th>Pros and Cons</th>
</tr>
</thead>
</table>
| **Connect live**       | Tableau will run a new database query as data elements are added or changed within the dashboard  
                         • Inefficient for development and will cause large query overhead on the database  
                         • Requires all Tableau dimensions and measures to be configured correctly otherwise improper SQL is passed down to the database (e.g., ID columns may be defaulted to measures in Tableau and be incorrectly aggregated) |
| **Import all data**    | Extracts all data from database based upon selected views and columns with no filters applied  
                         • Data extracts are stored locally in the Citrix environment and used by Tableau, providing the best performance  
                         • Data extracts can be refreshed fully or incrementally as needed  
                         • Could be extracting massive datasets, so must take data volume into account |
| **Import some data**   | Extracts all data from database based upon selected views and columns with defined filters and row limits  
                         • Data extracts are stored locally on Citrix and used by Tableau, providing the best performance  
                         • Data extracts can be refreshed fully or incrementally as needed  
                         • Allows you to specify query filters prior to extracting data  
                         • Allows you to return only a sample of the full dataset for development |
Note: If the **Import some data** option is selected, after the dashboard has been built and before publishing on the server, the desktop developer will have to import all data for holistic.

**Database Connection Options**

In the standard database connection window (below example from PostgreSQL), you may click and drag tables into the data area, or create Custom SQL.

<table>
<thead>
<tr>
<th>Data Connection Type</th>
<th>Pros and Cons</th>
<th>Recommended Approach</th>
</tr>
</thead>
</table>
| Single Table         | Connect to a single database view or table.  
  - Select specific columns to retrieve from view or table  
  - Not likely useful unless data has already been de-normalized into a single view  
  - Allows for incremental refresh of extracts | Yes |
| Multiple Tables      | A wizard-like, user interface that allows you to join multiple database views or tables together.  
  - Select specific columns to retrieve from each view or table  
  - Inner, Left, Right, and Full Outer joins all available, including multi-key joins | Yes |
### Data Connection Type

<table>
<thead>
<tr>
<th>Data Connection Type</th>
<th>Pros and Cons</th>
<th>Recommended Approach</th>
</tr>
</thead>
</table>
|                      | • Tableau generates SQL query based on selected columns and joins, then sends to database  
• Allows for incremental refresh of extracts |                       |
| Tip: When connecting to multiple tables, first select the **Single Table** radio button and the table. Then once a table has been selected, click on the **Multiple Tables** radio button to add multiple tables within the database. |                       |
| Custom SQL           | Requires coding of custom SQL to retrieve data.  
• More error-prone than using other options  
• Disallows Tableau filters to be pushed down to database query (they will be applied after the full custom SQL has completed)  
• Disallows use of incremental refresh for extracts, therefore will always require a full refresh | No |

---

### Connect to Sample Excel Data

To connect to an excel file:

1. Open Tableau Desktop
2. Select **Data > Connect to Data**
3. Click on **Microsoft Excel** listed under the **In a File** section.
4. The Windows Explorer dialog box will open.

5. Browse to the location ..\Documents\My Tableau Repository\Datasources\9.1\en_US-US. Sample – Superstore.xlsx. To connect to your non-xDR data sources, browse through DropOffs Folder located on Citrix.

6. The data connection box will now appear.

7. Click and drag the **Orders** table into the clear white space.

8. Select Extract for Connection Type

9. Preview the data to ensure it’s being imported as expected

10. Click **Go to Worksheet** to save the extract and import the data into the worksheet.

**Tips:**

- Use a file name that is detailed enough to best describe its contents.
11. The Data window seen below will populate with the dimensions and measures from the **Orders** table.

![Data window](image)

**Tip:** If you want to change settings in your data source after the initial import, you can use **Edit Data Source** to apply filters, change connection type, etc.,

![Edit Data Source dialog](image)

Save the workbook by clicking the save icon and name it **Class Training – Superstore Data.** The default save format will be a TBW (Tableau workbook).

**Creating an Extract**

If a live connection was chosen initially, you may change it to an extract by creating a data extract

1. Select **Data > Orders (Sample – Superstore) > Extract Data** to open the Extract Data dialog box.
2. Add Filters or specify number of rows to extract

**Note:** You can define filters by clicking the **Add** button under the Filters list to limit the data that will be extracted. Tableau will first apply any filters and aggregation and then extract the number of rows from the results.

![Extract Data dialog box](image)

3. Select a location to save the extract and click **Save**.

4. Save your workbook by clicking **File > Save as**.

![Warning message](image)

**Note:** A warning box may appear. Click the **OK** button.

**Extract Aggregation**

When selecting the **Aggregate data for visible dimensions** option, the measures are aggregated using their default aggregation. Aggregating the data can minimize the size of the extract and improve performance.

You may also choose to roll up the data to a specified year, month, day, etc., level.
Remove an Extract

1. Right-click on the Orders (Sample – Superstore) data extract connection. From the main tool bar, select Data > Orders (Sample – Superstore) > Extract > Remove.

2. A Remove Extract window will appear. Select an option and click OK.
   - Remove the extract — Converts to live data and requires reconnection to database.
   - Remove and delete the extract file — Converts to live data, removes and deletes the extract file from your hard drive.

Module Summary

You should now be able to:

- Understand difference between live connection and extracts
- See how to connect to a database
- Connect to sample Excel datasets
- Learn to create and remove a data extract
Module 3: Managing Data: Filtering, Sorting, Grouping, and Sets

Module Objectives

- Add a quick filter to the view
- Apply ascending and descending sorting using a stacked bar chart
- Define and create a grouping
- Understand the various applications for sets and create a set
- Copy and paste information between multiple sheets

Filters

Filters allow you to narrow the data down in a view or exclude certain information. They are defined by selecting specific dimension members or a range of measure values.

Note: Filters are applied to the view in the order they appear on the Filters shelf. However, when working with independent filters, the order of the filters in the filters shelf does not change the results.

Adding Filters

You can create a filter by dragging and dropping either a dimension or measure into the filters shelf. When you add a field to the filters shelf, the Filter dialog box opens so you can define the filter. The Filter dialog box differs depending on whether you are filtering a dimension, measure, or date field.

1. Create the following view:

![Chart Image]

Detailed Instructions:
a. Drag **Order Date** to the **Columns** Shelf.
b. Click the (+) on the left of **Year(Order Date)** to view a lower granulary **Quarter(Order Date)**.
c. Drag **Profit** to the Rows shelf.
d. Drag **Category** to the **Color** shelf on the Marks card.

2. Drag and drop the **Category** dimension into the Filter Shelf. A Filter window will open.

3. You can either select/deselect from the list or use the tabs at the top (Wildcard, Condition, Top). In this exercise, select the **Technology** value.

4. In the view, verify that only the **Technology** Category remains as a result of the filter.
5. Drag and drop the **Order Date** dimension into the Filters shelf.

6. Choose to filter on **Quarter**

7. Select only **Q1** and **Q2**. Click **OK**.

8. Verify only **Technology** for **Q1 and Q2** values are displayed in the view.

---

**Quick Filters**

When you turn on a Quick Filter, a smaller representation of the Filter dialog box opens as a new card. From there, you can quickly decide what to include in the view.

**Add Quick Filter**

1. Either right-click or click on the down arrow on a field in any of the shelves.

2. To add a quick filter for the **Order Date (Quarter)** dimension, select **Show Quick Filter**.

3. The **Order Date (Quarter)** quick filter is in the upper right corner of the view.
4. Within the **Quarter** quick filter, click on the down arrow to view quick filter options.

- **General Quick Filter Options:**
  - **Edit Filter** – opens the main Filter dialog box so you can further refine the filter by adding conditions and limits.
  - **Remove Filter** – removes the quick filter from the view
  - **Apply to Worksheets** – applies to all sheets that use the same data source, select specific worksheets, or just the current sheet

- **Categorical Quick Filters Options:**
  - **Multiple Values List** – Displays the values in the quick filter as a list of checkboxes where multiple values can be selected.
- **Single Value List** – Displays the values of the quick filter as a list of radio buttons where only a single value can be selected at a time. An “all” option can be added to the list to let you quickly select all values without switching to a multiple values list.

- **Compact List** – Displays the values of the quick filter in a drop-down list where only a single value can be selected at a time.

- **Slider** – Displays the values of the quick filter along the range of a slider. Only a single value can be selected at a time. This option is useful for dimensions that have an implicit order such as dates.

- **Wildcard Match** - Displays a text box where you can type a few characters. All values that match those characters are automatically selected. You can use the asterisk character as a wildcard character.

**Customizing Quick Filters**

The appearance of the quick filter controls can be altered and customized on worksheets, dashboards, or how it is published on Tableau Server.

1. Select **Customize** on the quick filter card menu.

2. Select from the following options:
   - **Show “All” Value** - toggles whether to show the “All” option that displays by default in multiple values and single value lists.
   - **Show Search Button** - toggles whether to show the search button at the top of the quick filter.
   - **Show Include/Exclude** - toggles whether to show the Include Values and Exclude Values commands on the quick filter card menu. When shown, users can switch the quick filter between include and exclude modes.
   - **Show Filter Types** - toggles whether to let users change the type of quick filter is shown. For example, when shown, a user can change a multiple values list to a compact list.
   - **Show More/Fewer Button** - toggles whether to show the More/Fewer button at the top of the quick filter.
   - **Show Readouts** - controls whether the minimum and maximum values are displayed as text above a range of values. The readouts can be used to manually type a new value instead of using the sliders.
Global Filter

A global filter is a filter that applies to all existing and future worksheets in the workbook that are connected to the same data source. The global filter can be identified by the database icon next to the filter in the Filters shelf.

Add Global Filter

1. With your mouse, hover over an existing filter on the Filter shelf.
2. Click on the drop-down button to access the option to Apply to Worksheets.
3. When you add that specific field to All Using This Data Source, the global filter will be added.

The field is marked with a database icon and the filter is applied to all worksheets in the workbook. Any changes you make to the filter affect all of the worksheets.

Make Global Filter Local

You can also make a global filter into a local filter again where it just applies to the active worksheet.

1. Select the drop-down on the global filter on the filter shelf and select Apply to Worksheets > Only this Worksheet.
2. Verify the database icon has been removed.

Tip: The filter can be applied to specified worksheets only one by one. Apply to Worksheets > Selected Worksheets.

Context Filters

If you are applying filters to a large data source, you can improve performance by setting up context filters. A context filter is applied to the data source first, and then the other filters are
applied only to the resulting records. This sequence avoids applying each filter to each record in the data source.

Create Context Filters

1. On the Filters shelf, right-click the appropriate filter and select *Add to Context.*
2. Verify the context filter appears at the top of the Filters shelf, is marked with context filter applied, and is colored grey.

![Filters](image)

_*Note:* The context filter will always be the first filter applied and cannot be rearranged on the shelf.

Sorting, Groups, and Sets Defined

You can use sorting, groups, and sets to further refine your views and extract exactly the information you are looking for.

- **Sorting** – Sorting a data view means arranging dimension members in a specified order.
- **Groups** – Combine dimension members into higher-level categories.
- **Sets** – Create a custom field based on existing dimensions that can be used to encode the view with multiple dimension members across varying dimension levels.

Sorting

There are two sorting types: computed and manual.

- **Computed Sorting** – automatically sorts data along dimensional items used in your view. By default, it sorts the category labels in ascending or descending alphabetical order or measurements in highest to lowest order.

- **Manual Sorting** – allows you to rearrange the order of dimension members in the table by dragging them in an ad-hoc fashion, giving precise control over how items appear next to one another in tables and in legends.

*Tip*

- You can sort any discrete field after it has been placed on a shelf (except the Filters shelf).
The shelf location of the dimension determines the component of the data view that’s sorted. For example, if the dimension resides on the Columns shelf, the columns of the data view are sorted for that field. If the dimension resides on the Color shelf, the color encodings are sorted.

**Apply Computed Sorting**

1. Recreate the below view:

   Detailed Instructions:
   
   a. Drag **Category** from the dimensions to the **Rows** shelf.
   
   b. Click on the (+) to the left of the **Category** field to see the view by **Sub-Category**. Otherwise, drag **Sub-Category** from the dimensions to the right of **Category**.
   
   c. Drag **Sales** from the measures to the **Columns** shelf.
   
   d. Drag **Profit** from the measures to the **Color** shelf on the Marks card.

2. Click on the down arrow of the **Sub-Category** dimension in the Rows shelf and choose Sort.
3. The **Sort** dialog box opens. In the **Sort order** section, select the **Descending** radio button. In the **Sort by** section, select the **Field** radio button and select **Sales** in the dropdown field.

![Sort dialog box](image)

4. Click **OK**. The bar chart is updated.

![Bar chart](image)

**Tip:** If you want to change sort order, select either **Ascending** or **Descending** on the main toolbar or axis, which is boxed in the above view.
In the Sort dialog box, you noticed you can choose one of the three options to sort by:

- **Data source order** - the order that the data source naturally orders the data. Generally for relational data sources, this tends to be in alphabetical order. If you are using a cube, this order is the defined hierarchal order of the members within a dimension.
- **Alphabetic** - the order of the letters in the alphabet.
- **Field** - order the data based on the associated values of another field. For example, you could order several products by their total sales values.

**Manual Sort Using the Toolbar**

The two sort buttons on the toolbar manually sort a selection either in ascending or descending order based on the other fields in the view.

1. Select a dimension in the view.
2. Hover over either the ascending or descending button on the toolbar to see a description of how the selection will be sorted.
3. Click on either the ascending or descending button; or right-click on the sorted field and select **Sort** to open the **Sort** dialog box.

**Manual Sort by Drag and Drop**

1. Select the dimension member you want to move. This can be any dimension member that appears in a row or column header of a table, or in a legend such as the color legend.
2. Drag the member to the desired location within that row, column or legend.

**Default Sort**

If you want make sure a dimension defaults to the same sort every time it is brought into the view, right-click or select the drop down on the dimension in the data pane, and navigate to **Default Properties > Sort**.
Clear Sort

To clear a sort, right-click on a field a legend or and select the drop-down of the Dimension that has the sort applied to it, and click on Clear Sort.

Grouping

A group is a collection of dimension members that have been combined into higher-level categories.

Create a Group

You can both use the group button on the toolbar, or right-click a dimension in the Data window and select Create > Group. For this demo exercise, you will be creating a group for the Product names starting with A, B and C.

1. Right-click on the Product Name dimension and select Create Group.

2. In the Create Group window, locate the Field Name: at the top and rename to Product Group.

3. Select Find >> to search for specific names.

4. Select Starts with and type in A and select Find All.
5. Now all “A” product names will be highlighted. Select Group to group these together.
6. Name the group A and note the paperclip icon to indicate that these are all grouped.

7. Repeat steps 3 to 5 for B and C.

Tip: Hold the CTRL key on your keyboard to select multiple members.

8. Check the Include ‘Other’ checklist to group all other product name values into an Other bucket

9. Suppress the groups to see all four listed

10. Click OK to apply.

11. Your dimensions data pane should result in the following new dimension field:
12. Drag the **Product Group** group and the **Product Name** field into the row data shelf to ensure the dimension values were grouped properly.

---

**Edit Group**

After you have created a group, you can add members to the group, change the default member names, as well as change the name of the grouped field using the Edit Group dialog box.

1. Right-click the grouped field in the Data window and select **Edit**.
2. To add members, drag and drop them into the existing group. Click **OK**.

**Create a Group by Selecting Marks**

Instead of using the data pane to create a group, you can create a group in the view itself.

1. Create the below view sorting **Sub-Category** by **Descending Order** by **Sales**.
2. Group Envelopes, Labels, and Fasteners together but clicking on each of their **labels** while holding **Ctrl**. A tooltip will appear, allowing you to choose the Group Members icon (⬜).

3. A Sub-Category (group) will be created and will replace the Sub-Category field on your rows shelf.

### Remove Group

You can quickly un-group the dimension members by right-clicking on a group name and selecting **Delete**.

### Sets

Sets are custom fields you create that are based on existing dimensions and that filter data using one or more criteria. You can create a set from any existing dimension. There are three main uses for sets:

- **Create a subset of the data** – Select one or more dimension members that are of interest to you. For example, select only categories that generate the most energy, or manually select outliers that appear in a scatter plot.

- **Create unique encodings** – Combine dimension members to create unique encodings. For example, create a set that combines child name and model, and then color-encode a data view using the combined members.
• **Save filters for later use** – once you have created a filter, you can save the filter as a set and use it in all of the worksheets in a workbook. This saves you from having to recreate the filter every time you want to use it.

**Tip:**

• Sets are always treated as a filter, so when you place a set on a shelf with the Show members in set option selected, it is automatically placed on the **Filters** shelf as well.

• If you want to save the sets you create, you should save your work as a workbook or a bookmark.

• Sets are published to the server with the workbook

**Create a Set by Selecting Marks**

Create a set by selecting marks if you want to create a subset of your data, and the data of interest can best be identified via the data view.

This exercise will utilize the Superstore Sales Subset workbook and data.

1. Create the following view of profit over time

2. Within your view, manually select the desired marks. Select all bars with profits over $20,000.

3. Right-click and select **Create Set**.
4. The Create Set From Selection dialog box opens. Name the set **High Profit Quarters** and click on OK.

5. Verify the set has been created at the bottom of the data window.
6. To test out the Set feature, open up a new worksheet and double-click on the set name at the bottom of the data window.

7. Initially the set will display two values In and Out. This breaks out the values that fall within the set criteria and those that fall out of it. Click on the drop-down of the set name in the shelf and select **Show Members in Set**.

8. Now only the values within the set will appear and the set has been added to the Filters card.
Tip: Ensure that you click on the drop-down of the Set and select **Show Members in Set** to have this view.

**Create a Set from a Field**

Create a set from a field if you want to create a subset of a specific field.

1. Right-click the field in Product Container dimension and select **Create Set**. The Create Set dialog box opens.

2. In the dialog box, name the set **Box Containers** and type **Box** to search for and select these items to include in the set.

3. Click the **OK** button.
4. Verify the new set is at the bottom of the data window.

<table>
<thead>
<tr>
<th>Sets</th>
</tr>
</thead>
<tbody>
<tr>
<td>Category Set</td>
</tr>
<tr>
<td>High Profit Quarters</td>
</tr>
</tbody>
</table>

Copy Crosstab/Data/Image from View

Copying certain information from a View can be done by right-clicking on any part of the view, selecting **Copy > Crosstab/Data/Image**

Copy Crosstab

1. Create the following view

2. Copy a Crosstab (Right Click > Copy > Crosstab) will display all of the data that is seen in the view into a simple format.
3. Paste Data in a New Worksheet or in MS Excel and a simple Crosstab view will show based on the data that you had copied.

Copy Data

1. Copying Data (Right Click > Copy > Data) will display the set of the data that you select. In our example, we will select year 2014 category and Q1.
2. Go to **Data > Paste Data** to paste the data into a new worksheet

3. A simple Crosstab view will show based on the data that you had copied.

![Crosstab View](image1)

**Copy Image**

1. Copying an Image (**Right Click > Copy > Image**) will allow you to paste your view to a Keynote File, for example.

2. You will be prompted to select the information that you’d like to paste in your File

![Copy Image Dialog](image2)

3. Paste Data in any file. The below image is a copied image.
Copy and Paste Information Between Workbooks

When working with multiple workbooks, you may find that you are setting up the same formatting, groups, and calculations in each one. Instead of creating these formats and fields from scratch each time, you can copy and paste between workbooks.

**Copy and Paste Groups or Custom Fields**

Custom fields between workbooks that use the same data source can be copied as well.

1. In the Dimensions pane, right-click the field you want to copy, and select Copy.
2. In the target workbook, right-click in the Dimensions pane, and select Paste.

Copy and Paste Sheets

You can copy and paste sheets between workbooks. Copying and pasting sheets also copies any information that the views in the sheets depend on, including formatting, groups, calculations, and more.

Copying and pasting sheets is a quick way to combine information from different workbooks or create a new workbook.

1. Open a workbook and display it in the filmstrip view.

2. Select the thumbnails of the sheets you want to copy, and then right click > Copy Sheet.

3. Tableau copies the information in the file format (.twb or .twbx) of the workbook.
4. Open the destination workbook, or create a new workbook, and select File > Paste Sheets.
5. Pasted sheets are placed after existing worksheets and dashboards.
6. Save the changes.
Module Summary

You should now be able to:

- Add a quick filter to the view
- Apply ascending and descending sorting using a stacked bar chart
- Define and create a grouping
- Understand the various applications for sets and create a set
- Copy and paste information between multiple sheets
Module 4: Building Views

Module Objectives

- Identify the various components of the Tableau Workspace focusing on the toolbar and data connection window
- Rename dimensions and measures and create a hierarchy
- Build a basic cross-tab view and change to other chart types
- Understand how to use cards and shelves to enhance a view
- Create a stacked bar using the Color Shelf

The Tableau Workspace

The Tableau workspace consists of menus, a toolbar, the Data window, cards that contain shelves and legends, and one or more sheets. Sheets can be worksheets or dashboards. Worksheets contain shelves, which are where you drag data fields to build views. You can change the default layout of the shelves and cards to suit your needs, including resizing, moving, and hiding them.

The illustration below highlights the various components of a Tableau workbook.
Data Connection Window

Data fields appear on the left side of the workspace in the Data window. You can hide and show the Data window by selecting Window > Show Side Bar. You can also click the minimize button in the upper right corner of the Data window.

Tip: You can search for fields in the Data and Dimensions window by clicking the magnifying glass icon at the top of the window.

Toolbar

You can undock the toolbar by grabbing its left edge and then dragging it to a new location. You can hide or display a toolbar by selecting Window > Show Toolbar.

<table>
<thead>
<tr>
<th>Term</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td><img src="image" alt="Undo" /></td>
<td>Undoes the last task you completed. There are unlimited undoes in Tableau.</td>
</tr>
<tr>
<td>Redo</td>
<td><img src="image" alt="Redo" /></td>
<td>Repeats the last task you canceled with the Undo button.</td>
</tr>
<tr>
<td>Save</td>
<td><img src="image" alt="Save" /></td>
<td>Saves changes made to the workbook.</td>
</tr>
<tr>
<td>Connect to Data</td>
<td><img src="image" alt="Connect to Data" /></td>
<td>Opens a dialog box where you can create a new connection or select one from your repository.</td>
</tr>
<tr>
<td>New Worksheet or Dashboard</td>
<td><img src="image" alt="New Worksheet or Dashboard" /></td>
<td>Creates a new blank worksheet or Dashboard</td>
</tr>
<tr>
<td>Duplicate Worksheet</td>
<td><img src="image" alt="Duplicate Worksheet" /></td>
<td>Creates a new worksheet containing the exact same view as the current sheet.</td>
</tr>
<tr>
<td>Clear Sheet</td>
<td><img src="image" alt="Clear Sheet" /></td>
<td>Clears the current worksheet. Use the drop-down list to clear specific parts of the view such as filters, formatting, and sizing.</td>
</tr>
<tr>
<td>Pause Automatic Updates</td>
<td><img src="image" alt="Pause Automatic Updates" /></td>
<td>Controls whether Tableau automatically updates the view when changes are made. Use the drop-down list to control updates on the entire sheet or just quick filters.</td>
</tr>
<tr>
<td>Run Update</td>
<td><img src="image" alt="Run Update" /></td>
<td>Runs a manual query of the data to update the view with changes when automatic updates are turned off. Use the drop-down list to update the entire sheet or just quick filters.</td>
</tr>
<tr>
<td>Swap</td>
<td><img src="image" alt="Swap" /></td>
<td>Moves the fields on the Row shelf to the Column shelf and vice versa.</td>
</tr>
<tr>
<td>Sort Ascending</td>
<td><img src="image" alt="Sort Ascending" /></td>
<td>Applies a manual sort in ascending order of a selected field based on the measures in the view.</td>
</tr>
</tbody>
</table>
### Tableau User Guide

<table>
<thead>
<tr>
<th>Term</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fit</td>
<td><img src="image" alt="Normal" /></td>
<td>Specifies how the view should be sized within the application window. Select either Normal fit, Fit Width, Fit Height, or Entire View.</td>
</tr>
<tr>
<td>Fix Axes</td>
<td><img src="image" alt="Axes" /></td>
<td>Toggles between locking the axes to a specific fixed range and showing all of the data in the view.</td>
</tr>
<tr>
<td>Highlight</td>
<td><img src="image" alt="Highlight" /></td>
<td>Turns on highlighting for the selected sheet. Use the options on the menu to define how values will be highlighted.</td>
</tr>
<tr>
<td>Show Me!</td>
<td><img src="image" alt="Show Me" /></td>
<td>Displays up to twenty alternate views of the data, in addition to the best view according to best practices. The options presented when this button is clicked depend on the data fields that have been selected.</td>
</tr>
</tbody>
</table>

### Dimensions and Measures Fields

Once you are connected to data, the Data Window will populate with the corresponding dimensions, measures, sets, or field types.

- **Dimensions** – Fields that typically hold discrete qualitative data. Examples of dimensions include dates, categories, model names, etc.,
- **Measures** – Fields that typically hold numerical data that can be aggregated. Examples of measures include value metrics such as usage, sales, etc.,

In addition to dimensions and measures, each field is categorized as either discrete or continuous. Below are example graphs illustrating the difference between these two data roles. Both examples show the Sum of Sales with the order quantity. It is the same information presented in two different ways.
Whether a field is continuous or discrete is reflected in the color of the field’s data type icon. In the Data window, blue icons indicate discrete and green icons indicate continuous fields.

Discrete fields always result in headers being drawn whenever they are placed on the row or columns shelves. Continuous fields always result in axes when you add them to the view. These roles are important because you may want to display your data continuously or discretely depending on the data structure and what you are trying to see.

In the example above, if there is a gap for Order Quantity with a value of 5, you will not see a bar or header for it if it’s a discrete value. If it’s a continuous, you will see 5 on the axis with the value of 0. Continuous shows all continuous values on the axis.

You can switch between continuous and discrete data roles by right-clicking on the field in the shelf.
Change Measure to Dimension

During the data import process, Tableau will do its best to identify the Measures and Dimensions in your data set. However, sometimes, Tableau will categorize the data into the wrong classification. You can change this by dragging the field from the Measures section to the Dimensions section or from the Dimensions section to the Measures section.

Rename Fields

It is important to rename fields before building your views, as the field names will appear in the views. It is recommended to rename fields to business friendly names, especially if they are coming from a data warehouse.

Adding a Comment to a Field

Fields can have comments that describe them. The comments display in a tooltip in the Data window and in the Calculated fields dialog box. Field comments are a good way to give more context to the data, especially when you are building a workbook for others to use.

1. Right-click a field in the Data window and select Default Properties > Comment.

2. Write a comment in the dialog box. When finished, click OK.

Note: Comments are descriptions of the fields. There is another concept within Tableau called annotation that displays comments on the graph and charts. More on this feature in a future module.
Adding Aliases

Aliases are alternate names for specific values within a dimension.

1. Right-click the Region dimension and select Default Properties > Aliases.

2. In the dialog box, modify all the Alias to include US prior to their name.

3. Click OK.

Note: Aliases can only be applied to dimension and do not apply to Measures.

You can change aliases at any time using the Edit Aliases dialog box. To restore the original aliases, click the Clear Aliases button.

Hierarchies

Data hierarchies are organization of data of similar fields for a specific dimension. Dimensions of hierarchies have the +/- sign in the Data window.

You can expand or collapse the various areas or hierarchies in a multidimensional Data window by clicking the + button.
Using Hierarchies in Shelves

You can drill down or drill up by clicking on a dimension that is placed on any shelf. If the dimension is on the Rows or Columns shelf, drilling down shows more data, or headers, in the table, while drilling up shows less data in the table.

If a dimension shows the plus sign +, then its children are not already showing and you can drill down at least one level. If the dimension member shows the minus sign -, then its children are already showing and you can drill up.

Tip: The order that the hierarchical dimensions are placed in the columns and rows shelf indicates order of priority.

Creating a Hierarchy

1. Right-click Region in the Data window and select Create Hierarchy.
2. Type a name for your hierarchy. For training, type "Region/State/City" and click OK.
3. Drag and drop a field directly on top of another field.
   For the in-class demonstration, create hierarchies and arrange as per the image below.
Note: The order of the fields within a hierarchy will impact how the data is displayed in the report. The hierarchy should have the fields grouped from top to bottom. A Fiscal hierarchy with the order of Fiscal Year, Fiscal Quarter, Fiscal Month, and Fiscal Week is very different from order of Fiscal Week, Fiscal Month, Fiscal Quarter, and Fiscal Year.

Hierarchies can be removed by right-clicking the hierarchy and selecting Remove Hierarchy.

Folders

Folders are a good way to visually organize data in Tableau. Any dimension, measure, or even hierarchies and groups can be placed into a folder. Fields are still searchable when inside folders. Folders are useful when there are 20+ dimensions or when it becomes messy and difficult to find the field you need.

Creating a Folder

1. Right click on the Customer Name field and select Group By > Folder. This allows you to organize fields by folders instead of by data source.

2. Select the Customer Name and ID dimensions. Then, right-click select Create Folder.

3. Type a name for your folder. For training, type “Customer” and click OK.

4. Folders can be removed by right-clicking the Folder and selecting Remove Folder.

Building a Tableau View

You can build views of your data by dragging fields from the Data window to the view.
Tip: In general, dimensions will add row and column headers while measures will add an axis.

Working with Text Tables (Cross-tab)

Text tables show measures with text. It provides a way to display measures relative to different values of a dimension. Tables are useful when it is important to look up individual data points.

A typical selection is at least one measure and one dimension.

1. Drag the City dimension into the Rows shelf.

2. Drag the Region dimension into the Columns shelf.

Tip: If the cross-tab has Abc in the cell fields, it means a measure has not been added to that field within the cross-tab.

3. Drag and drop the Value measure into table over the Abc text.
Notice the cross-tab will populate with the aggregate sum of Sales as indicated by the SUM function in the Marks card.

Tip: When a field is double-clicked within the Dimensions and Measures in the Data Window, Tableau will use its best practices built into the tool to determine if it should be in the Column or Row shelf.

4. Click the Swap button to see how the view changes.

Keep Only, Exclude, or Hide

Once the view has been created, you can modify and customize the information you want to display. You can keep, exclude, or hide data by right-clicking on a column or row header. These selections will be applied as a filter and can be seen in the Filters shelf.
Working with Cards and Shelves

Every worksheet contains a variety of different cards, or containers, for shelves, legends, and other controls.

The following list describes the most common cards:

- **Columns** – contains the Columns shelf where you can drag fields to add columns to the view.
- **Rows** – contains the Rows shelf where you can drag fields to add rows to the view.
- **Pages** – contains the Pages shelf where you can create several different pages with respect to the members in a dimension or the values in a measure.
- **Filters** – contains the Filters shelf; use this shelf to specify the values to include in the view.
- **Quick Filters** – a separate quick filter card is available for every field in the view. Use these cards to easily include and exclude values from the view without having to open the Filter dialog box.
- **Marks** – contains a mark selector where you can specify the mark type as well as the Path, Shape, Text, Color, Size, Angle, and Detail shelves. The availability of these shelves are dependent on the fields in the view.
- **Color Legend** – contains the legend for the color encodings in the view and is only available when there is a field on the Color shelf.
- **Shape Legend** – contains the legend for the shape encodings in the view and is only available when there is a field on the Shape shelf.
- **Size Legend** – contains the legend for the size encodings in the view and is only available when there is a field on the Size shelf.

Rearranging Cards

1. Point the cursor at the title area of the card you want to move. When the cursor becomes the move symbol, click and drag the card to a new position.
2. As you drag the card around the worksheet, the possible positions for it are highlighted with a black bar.
Note: The Undo button only works for the views, not for undoing reordering of cards.

Types of Shelves

Every worksheet in Tableau contains shelves. Cards are containers for shelves. Shelves are fields where customizations are made. By placing fields on shelves, you can create the rows and columns of a data view, exclude data from the view, show additional levels of detail, and encode the data in various ways.

Some shelves include the following:

- Columns and Rows Shelves
- Pages Shelf
- Filters Shelf
- Detail Shelf
- Color Shelf
- Size Shelf
- Shape Shelf
- Label Shelf
- Path Shelf

Note: Some shelves are available only when certain mark types are used. For example, the Shape shelf appears when the shape mark type is used.

Tip: You should experiment with various combinations of shelves, fields, and mark types to find the optimal view for your data.

Columns and Rows Shelves

The Columns shelf creates the columns of a table, while the Rows shelf creates the rows of a table. You can place an unlimited number of fields on these shelves.
When you place a dimension on the Rows or Columns shelf, headers for the view are created. When you place a measure on the Rows or Columns shelf, quantitative axes for that measure are created. As you build up your data view with more fields, additional headers and axes are included in the table. Using the filters based on the Rows and Columns shelves may enable you to get an increasingly detailed picture of your data.

**Pages Shelf**

The Pages shelf lets you break a view into a series of pages so you can better analyze how a specific field affects the rest of the data in a view. When you place a dimension on the Page shelf you are basically adding a new row for each member in the dimension. When you place a measure on the Pages shelf, the measure is converted into a discrete measure.

The page shelf creates a view on a different page for each new row so you can easily flip through each view and compare them on a common axis.

**Filters Shelf**

The Filters shelf allows you to specify which data to include and exclude. For example, you might want to analyze the profit for each model, but only for certain locations or dates. By placing fields on the Filters shelf, you can create such a view.

**Tips:**

- You can filter data using measures, dimensions, or both at the same time.
- The order of fields placed on the Filters shelf does not affect the data view because the filters are independent.

**Detail on Marks Card**

The Detail also allows you to separate the marks in a data view according to the members (levels of detail) of a dimension. However, unlike using the Rows and Columns shelf, using this shelf is a way to show more data without changing the table structure.

**Tips:**
You can place any number of dimensions on the Detail shelf. In fact, placing all dimensions on this shelf is one way to display all the rows of your data source.

Placing a measure on the Detail shelf has no effect because measures do not contain members.

Note: The Detail shelf works only if the measures that contribute axes to the table are aggregated.

Color Shelf

The Color shelf encodes data by assigning different colors to the marks in a data view based on the values of a field. The effect of color-encoding your data view depends on whether you use categorical or quantitative colors.

- **Categorical Colors** - When you add a dimension to the Color shelf a categorical legend is added based on the members in the dimension field.

- **Quantitative Colors** - When you add a measure to the Color shelf a quantitative legend is added creating a continuous range of colors.

- **Transparency** - Is especially useful in dense scatter plots or when you are looking at data overlaying a map or background image. As you slide the slider toward the left the marks become more transparent.

- **Effects** – Use effects to add borders to data points or highlight data points.

Changing Colors to a Field

When you create a view, default colors are assigned to the field’s values. The colors used will be consistent across all worksheets for that field. You can change the colors for the fields.

1. Click on the down arrow button in the Child Name card.
2. Select **Edit Colors**. The Edit Colors box opens.

3. Under **Select Color Palette**, click on the down arrow to see the variety of options.

4. Select a color option.

5. Click on **Assign Palette**.

6. Click **Apply**. Click **OK**.

   **Tip:** Tableau will warn you if you have too many data items for a particular palette.

### Size Shelf

The Size shelf allows you to encode data by assigning different sizes to the marks in a data view. Depending on whether you use a discrete or continuous field you will add either categorical or quantitative size encodings.

- Categorical Sizes – categorical sizes work best for ordered data like years or quarters.
- Quantitative Sizes – the smallest value is assigned the smallest sized mark while the largest value is represented by the largest mark.
Shape Shelf

The Shape shelf allows you to encode data by assigning different shapes to the marks in a data view. Marks are separated into different shapes according to the members of the chosen dimension.

Label Shelf

The Label shelf allows you to view the numbers associated with a data view, and to encode data by assigning text labels to the marks.

Path Shelf

The Path shelf allows to encode the data and draw a path between lines or polygons based on a particular order. A path can be encoded based on a date, dimension, or measure. The shelf only appears when line or polygon is selected as the mark type.
Other View Types

Tableau offers many different types of views to slice and dice and showcase what you want to highlight in your data. The available view types will depend on the dimensions and measures you select.

Determine Views Available: Show Me!

There are two ways that the Show Me! Button can help you visualize your data.

Option 1: The Show Me! feature will display available view types based on the dimensions and measures already added to the Rows and Columns shelves.

1. Click on the Show Me! button on the toolbar.

2. Based on the dimensions and measures selected in the Columns and Rows Cards, Tableau will recommend the best representation of the data. For this example, the best data view is the aligned bar view.

3. Click **OK**. The bar chart view displays.

4. Click on Show Me! button again and select the various chart options that Tableau recommends. Notice as each chart type changes where Tableau re-arranges the dimensions and measures on the shelves and cards.
   - Heat Map
   - Highlight Table
   - Pie Chart
- Stacked Bar
- Circle
- Tree Map
- Box-and-Whisker Plot

**Option 2 to create View:** Even before adding dimensions and measures into the Rows and Columns shelves, you can select dimensions and measures fields in the Dimension and Measures window and click on the Show Me! Button and Tableau will display which visualization(s) will be best for the dimensions and measures selected.

Below are the different various types of visualizations that Tableau offers. Play around and re-create the visuals in the graphics below to gain a better understanding of how each visual works.

**Heat Map**

A Heat Map enables easy comparison of categorical values using color ranges. It shows measures with the size and color of square marks. A typical selection is two dimensions and one measure.
Highlight Table

Shows measures with color fill behind text based on the ranges of the measure. Requires at least one measure and dimension.

Pie Chart

The pie chart can be used to show proportions. A typical selection is one measure and one dimension.
Stacked Bar

A Stacked Bar is good for showing overall trend across categories or over time while comparing the trend within categories. A typical selection is one measure and two dimensions.

Histogram

A histogram shows the distribution of a single measure grouped into several bins based on the range of values. Tableau provides smart bin size suggestions for the data that can be edited by the user.

Histograms show the distribution of a measure, while bar charts compare dimensions.
Line Charts

Line charts can be used to display sequential numeric values. Most commonly used to display trends over time. To build Line Charts, 1 date dimension and 1 measure is required.

Area Charts

Area charts can be used to display total values so that the user can get an idea of how a dimension is contributing to an overall trend. To build Area Charts, 1 date dimension, and 1 or more measures are required.
Scatter Plot

A scatter plot allows a user to investigate the relationship between multiple variables. Adding trend lines can more clearly define the correlations between your data. A typical selection is 2 measures and at least 1 dimension.

Creating a scatter plot with the Superstore Subset workbook provides a better example. You will need to create a scatter in the dashboard creation later.

Box-and-Whisker Plot

Box-and-whisker plots depict the distribution of a set of data and are efficient at displaying outliers. There is a line at the median of the data, a box above and below the median for the nearest quartiles, and a set of “whiskers” that can extend to the entire data range or the nearest data points within 1.5 times the interquartile range. Requires at least one measure.
**Bullet Chart**

Bullet charts are meant to compare two measures together, most commonly an actual vs a goal. Bullets were designed to replace the traditional gauges due to most information being displayed and more efficient use of space. Requires at least 2 measures.

**Mapping**

When you are connected to data that contains location information you can automatically show the data on a geographic map.
Tree Map

Tree maps are designed to display hierarchical data as rectangles within rectangles. For each rectangle, two measures can be coded – one will affect the size of a rectangle, and the other will affect color. If a single dimension is used, all dimension members will appear in size and color-encoded together.

Word Cloud

Word Clouds could display members of a chosen dimension as text, but in varying colors and sizes, depending on one or two measures. Word Clouds are tree maps, except with Text as the chosen mark type.
Packed Bubbles

Packed Bubble charts allow you to look at categorical data represented by the number of bubbles as well as the quantitative data by the size of those bubbles. Additionally, you can add colors to delineate between each of the categories.

Exercise: Create View

Create a basic view of Sales over time by the different Product Categories

Module Summary

You should now be able to:

- Identify the various components of the Tableau Workspace focusing on the toolbar and data connection window
- Rename dimensions and measures and create a hierarchy
- Build a basic cross-tab view and change to other chart types
- Understand how to use cards and shelves to enhance a view
- Create a stacked bar using the Color Shelf
Module 5: Calculated Fields and Formulas

Module Objectives

- Create a calculated field
- Understand when to use formulas and the various components

Calculated Fields

Sometimes your data source may not include all of the fields needed to analyze and answer your business question. Sometimes the data does not exist in the perfect format you want it to be in. Tableau allows you to create a new calculated field by defining a formula that is based on existing fields.

For example, if you extract Customer Emails from EBS, you may notice that the formats may vary. If you prefer to have all emails in a standard format, you may use a calculated field to apply a Tableau function to display the email in all lower or upper case.

Formulas

Calculated fields require formulas. The formula editor has built-in coloring and validating to help avoid syntax errors.

- As you write a formula, syntax errors are underlined with a red squiggly line. Hover over the error to see directions for fixing it.
- When the calculation is valid, a green check mark is displayed.
- Any part that displays in bold indicates that it will be computed locally within Tableau on the aggregated results.

Formulas are made up of the following parts:

- **Functions** – Enable you to create a calculation. Functions are organized to categories: number, string, date, type, logical, aggregate, User Functions, etc.
  - You can display a brief description for each function by clicking its name in the list box.
  - Double-click a function to include it in a formula.
  - Functions are colored blue in the formula.

- **Fields** – All data source fields and calculated fields are listed in the Fields area of the dialog box.
  - Double-click a field name to include it in a formula.
  - Fields are colored orange in the formula.
• **Operators** - Operators are not available on the dialog box like functions and fields. Instead, you must manually type the operators into your formula. For a complete list of operators see Appendix E.

• **Parameters** - Parameters are placeholders variables that can be inserted into calculations to replace constant values.

  Parameters are colored purple in the formula.

  Parameters will covered later in this training.

• **Comments** - You can insert custom comments for your calculations as a means of annotation for later review. To add a comment to a calculation type two forward slash characters into the formula pane.

**Creating a Calculated Field**

1. In the toolbar, select **Dimension/Measure > Create > Calculated Field** or right-click inside the Measures data window and select **Create Calculated Field**.

2. In the **Calculated Field** dialog box, type in a name for the new field. For this exercise, name the field **Profit Revenue**.

3. The formula that we will be using is: **IF [Category] = “Net Revenue” THEN Value END**

   This formula is evaluating the value in the field Value Type, which specifies which metric we are looking at. If the value is Net Revenue, then it returns the number in the Value column, otherwise it returns NULL.
Click **OK**. Verify the new **Net Revenue** measure field appears in the data window.

4. Create two-three more calculated fields for the different metrics.

   - The new calculated field displays in either as a Dimension or Measure with the = icon.
   - Calculations that return a string or date are dimensions, while calculations that return a number are measures.
   - Calculated fields are available to all sheets that use the same data source in a single workbook.

**Module Summary**

You should now be able to:

- Create a calculated field
- Understand when to use formulas and the various components
Module 6: Table Calculations

Module Objectives

- Understand table calculations
- Apply quick table calculations

Table Calculations Overview

Table Calculations are computations that are applied to the values in the entire table and are often dependent on the table structure itself. All table calculations are computed locally using the values you see in the table.

You can add table calculations to your view using either the predefined quick calculations or by specifying a custom definition. To create a table calculation, you need to define both what you want to compute and what to compute along.

Addressing and Partitioning

Table Calculations rely on two types of fields: addressing and partitioning fields. The key to understanding Table Calculations is to know how these fields work.

Partitioning fields partition your data into separate buckets, each of which is acted on by the calculations.

Addressing fields define the “direction” that you want your calculation to take.

Common Addressing options include:

Table (Across)

This option sets the addressing to compute along the entire table moving horizontally through each partition. For example, the view below shows quarterly sales by region and product category. When a calculation addressing is set to Table Across, the fields that span horizontally across the table are the addressing fields (Category and Region). All the other fields (Year, Quarter) are partitioning. The addressing fields are shown in orange while partitioning fields are shown in blue.

That means that each partition will be the combination of Year and Quarter.
Table (Across then Down)

This option sets the addressing to compute across the entire table horizontally and then down the table vertically. This means that both the fields that span across the table and down the table are addressing fields.

<table>
<thead>
<tr>
<th>Year of Order Date</th>
<th>Quarter of Order Date</th>
<th>Furniture</th>
<th>Category / Region</th>
<th>Office Supplies</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Central</td>
<td>East</td>
<td>South</td>
</tr>
<tr>
<td>2009</td>
<td>Q1</td>
<td>$54,929</td>
<td>$6,913</td>
<td>$234,484</td>
</tr>
<tr>
<td></td>
<td>Q2</td>
<td>$97,464</td>
<td>$40,000</td>
<td>$120,000</td>
</tr>
<tr>
<td></td>
<td>Q3</td>
<td>$86,784</td>
<td>$45,010</td>
<td>$130,000</td>
</tr>
<tr>
<td></td>
<td>Q4</td>
<td>$74,210</td>
<td>$50,000</td>
<td>$140,000</td>
</tr>
<tr>
<td>2009</td>
<td>Q1</td>
<td>$64,389</td>
<td>$41,043</td>
<td>$34,192</td>
</tr>
<tr>
<td></td>
<td>Q2</td>
<td>$71,341</td>
<td>$68,765</td>
<td>$103,714</td>
</tr>
<tr>
<td></td>
<td>Q3</td>
<td>$84,215</td>
<td>$79,408</td>
<td>$195,540</td>
</tr>
<tr>
<td></td>
<td>Q4</td>
<td>$54,478</td>
<td>$107,409</td>
<td>$283,460</td>
</tr>
</tbody>
</table>

Pane (Down)

This option sets the addressing to compute down the table within the pane. The fields that separate the pane (Category and Year) are partitioning fields. In addition, the Region field becomes a partitioning field while the Quarter field is the addressing field.

<table>
<thead>
<tr>
<th>Year of Order Date</th>
<th>Quarter of Order Date</th>
<th>Furniture</th>
<th>Category / Region</th>
<th>Office Supplies</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Central</td>
<td>East</td>
<td>South</td>
</tr>
<tr>
<td>2008</td>
<td>Q1</td>
<td>$64,000</td>
<td>$48,000</td>
<td>$28,000</td>
</tr>
<tr>
<td></td>
<td>Q2</td>
<td>$71,464</td>
<td>$50,000</td>
<td>$130,000</td>
</tr>
<tr>
<td></td>
<td>Q3</td>
<td>$86,784</td>
<td>$45,010</td>
<td>$130,000</td>
</tr>
<tr>
<td></td>
<td>Q4</td>
<td>$74,210</td>
<td>$50,000</td>
<td>$140,000</td>
</tr>
<tr>
<td>2009</td>
<td>Q1</td>
<td>$64,389</td>
<td>$41,043</td>
<td>$34,192</td>
</tr>
<tr>
<td></td>
<td>Q2</td>
<td>$71,341</td>
<td>$68,765</td>
<td>$103,714</td>
</tr>
<tr>
<td></td>
<td>Q3</td>
<td>$84,215</td>
<td>$79,408</td>
<td>$195,540</td>
</tr>
<tr>
<td></td>
<td>Q4</td>
<td>$54,478</td>
<td>$107,409</td>
<td>$283,460</td>
</tr>
</tbody>
</table>

Other Addressing options include:

- Table (Down)
- Pane (Across)
- Pane (Across then down)
- Cell
Quick Table Calculations

You can add common table calculations to your view using the Quick Table Calculations menu item on the field context menus. These quick calculations are predefined table calculations based on the most common scenarios.

- Running Total
- Difference
- Percent Difference
- Percent of Total
- Moving Average
- Year to Date (YTD) Total
- Compound Growth Rate (CAGR)
- Year over Year Growth
- Year to Date (YTD) Growth

Adding a running total quick calculation

1. Create the following view of Sales by Y/Q/M

2. Select the drop-down arrow on the SUM(Sales) measure and select Quick Table Calculation > Running Total
The bar graph will now add up all the sales for each bar in the chart to get a running total. A triangle icon next to the Sum(Sales) indicates a table calculation.

3. Select the drop-down on the SUM(Sales) measure again to change the addressing type to **Pane (Across)**. This can be done under **Compute using**
4. Notice the running total is done in each quarter pane separately. Once a new quarter begins, the running total starts back at 0.

Adding a Ranking Quick Calculation

1. Create the following view of sales by City sorted by Sales

2. Click and drag another instance of Sales to the marks Detail shelf and create a quick calculation for rank
3. Drag the Ranked instance of Sum(Sales) to the filter card. A filter box will now appear. Filter on the rank values of 1 to 10 to show the top 10 child names.


**Tip:** There are other ways to filter for top N in charts. You may filter on a dimension and select ‘top’. However, with that method, other filters may interact with the dataset and it may not show the correct N number chosen. Filtering by rank will return the top N rank after the other filters have been applied.

**Module Summary**

You should now be able to:

- Understand table calculations
- Apply quick table calculations
Module 7: View Enhancements: Formatting, Annotations, and Labels

Module Objectives

- Identify the various options to enhance your view and make interactive
- Apply basic formatting for fonts, alignment, shading, borders and lines
- Add annotation, labels, and tooltip to highlight data and facilitate analysis

Formatting Worksheet

Formatting is an important part of both your analysis and presentation. You can format almost everything you see on a worksheet including the fonts, shading, alignment, borders, and graph lines.

These format settings can be specified using the Format window. When opened, the Format Window replaces the Data window on the left side of the worksheet. There you can use a series of drop-downs to specify format settings for the entire sheet, all rows, or all columns.

Opening the Format Window

1. On the main menu, select **Format**.
2. Select any formatting option to open the window: Font, Alignment, Shading, etc.
Verify that the format window replaced the data window.

![Tableau chart]

**Font Setting**

For the entire worksheet, you can specify the font, style, size, and color for both the pane text and header text.

1. In the Format window, select the Font command on the toolbar.
2. You can select to change the fonts for the sheets, rows, or columns.
3. In the example below, the worksheet font has been changed to Arial 12pt, Bold.

![Tableau chart with Font settings]

**Alignment**

Alignment allows you to control whether text is aligned horizontally, vertically, and the direction and wrapping of text.

- **Horizontal** - controls whether the text aligns on the left side, right side, or is centered.
- **Vertical** - controls whether the text aligns across the top, middle, or bottom.
- **Direction** - rotates the text so that it runs vertically or horizontally.
- **Wrap** - controls whether long headers and pane text wrap to the next line rather, than being abbreviated.

1. In the Format window, select the Alignment button on the toolbar to see the Alignment format settings.

2. Like font, you can change the alignment of the entire worksheet, rows, or columns and determine the horizontal, direction, vertical or wrap of the text.

![Alignment Settings](image)

**Shading**

Shading controls the background color of the pane and headers for normal areas, totals, and grand totals.

To make text tables easier to read, you may want to alternate the color from row to row or column to column, often referred as banding.

1. In the Format window, select the Shading button on the toolbar to see the Shading format settings.

2. Determine if you want the entire worksheet, row, or just columns to have the shading altered.

3. Select the color you want the bands to be for either the pane or the header areas.

4. Select the band size, or frequency of bands, by sliding the Band Size either to the left or to the right.
Borders

Borders are the lines that surround the table, pane, cells, and headers in a view. You can specify the border style, width, and color for the cell, pane, and header areas.

Borderlines are particularly helpful when you have multiple dimensions on the row shelf.
Lines

The lines settings control the lines that are part of the graph such as grid lines and zero lines as well as lines that help you inspect data such as trend lines, reference lines, and drop lines. You can specify the style, width, and color for each of these lines.

1. In the Format window, select the Lines button on the toolbar to see the Lines format settings.

2. Determine if you want the entire worksheet, row, or just columns to have lines.

3. You can alter the line, line width, and color for the grid lines, zero lines, trend lines, ref lines, drop lines, axis rulers, and axis ticks.

Format Specific Setting

Instead of formatting the entire worksheet, you can format specific settings by right-clicking a specific part of the view and selecting Format. You can format fields, numbers, legends, title and caption, null values, and reference lines and bands.
Modify Fields

Rather than formatting all rows or all columns in a worksheet, you can specify format settings that only apply to a specific field in the view.

1. Right-click the part of the view you want to format and select Format.
2. The Format window opens containing settings relevant to the selected field.
3. Modify the desired settings.
4. When finished, click the X in the upper right corner of the Format window to return to the Data window.

Numbers

When you format a measure, you can specify the number format for both the axis and the pane text. You can select from a set of standard formats, such as number, currency, scientific, and percentage.

1. Right-click a measure or axis in the view and select Format.
2. In the Format window, click the Numbers drop-down.
3. Select a number format.
4. When finished, click the X in the upper right corner of the Format window to return to the Data Window.
Note: Some formats require additional settings. For example, if you select Currency (Custom), you must also specify the number of decimal places, how to treat negative values, the units, a prefix or suffix, and whether to include thousands separators.

Field Labels

Field labels are row and column headings that indicate the data fields used to create the Table. When field labels are showing they display in three different parts of the view: rows, columns, and the corner. You can format the font, shading, alignment, and separators for each of these types of field labels.

1. Right-click on a field label in the view and select Format.
2. In the Format window, specify setting the font, shading, and alignment of the field labels.

Legends

When you encode the marks using the color and size shelves a legend card displays in the worksheet. You can format the legend font, shading, border, and alignment.

1. Right-click on the Class Description legend and select Format Legend.
2. In the Format window, specify settings for the body and title of the legends.
3. To edit the legend title, right-click inside the legend and select Edit Title.

Note: The legend format settings apply to all legends, you cannot format individual legends separately.
Add View Title

1. In the main toolbar, select **Worksheet > Show Title**. The Title shelf will appear. Double click in the empty space to edit Title.

2. Type in the view title and modify the text and format the font, size, style, color, and alignment.

3. When finished, click **OK**.

4. You may also double click on the sheet tab at the bottom and name the view from here.

5. When you print to PDF or include in a dashboard, the view title will appear.

Add View Caption

Captions are helpful in providing more detailed information about a view. When saving as PDF, captions will show up at the bottom of a view.

1. In the main toolbar, select **Worksheet > Show Caption**. The caption box will appear in the bottom section of view. Double click anywhere in the white space to edit Caption. A dialog box will appear.

2. Type in the information you would like displayed and format the font, size, style, color, and alignment.

3. When finished, click **OK**.
4. When you print to PDF, the caption is included at the bottom of the view.

Resize Tables

Tableau allows you to change the size of the rows, columns, and cells that compose a table.

Resizing Entire Table

You can increase or decrease the size of the entire table by selecting Bigger or Smaller on the Format > Cell Size menu. This option increases both the width and height of the panes.

Resizing Rows and Columns

Sometimes the rows and columns are not quite wide or tall enough. You can manually drag the header and axis borders in the view to change the row and column size.

1. Place your cursor over the vertical or horizontal border of a header or axis.
2. When you see the resize cursor, click and drag the border left and right or up and down.

Resizing Cells

Any table you can create in Tableau has the cell as its basic component.

1. On the main menu, click on Format > Cell Size.
2. Select the desired cell size.

Tips:

- **Square Cell** – adjusts the view so the cell has a 1:1 aspect ratio, which is particularly useful for heat maps.
- **Text Cell** – Adjusts the view so the cell has a 3:1 aspect ratio. This is particularly useful for text tables.
- After changing the cell size, you can use Ctrl+B and Ctrl+Shift+B to decrease or increase the table size while maintaining the cell aspect ratio.
Edit Axes

When you add a measure to the Columns or Rows shelf, you add an axis to the view. For each axis you can specify the range, scale, tick mark properties, and more.

Axis formatting options are available in the Edit Axis dialog box.

Changing Axis Range

You can limit the axis range in order to focus the view to where the data points lie.

1. Right-click on the axis that you want to edit and select Edit Axis.

2. In the Edit Axis dialog box, select one of the following:
   - **Automatic** - The axis range is automatically decided based on the data used in the view.
   - **Uniform axis range for all rows or columns** - the axis range is the same across all panes in the view.
   - **Independent axis ranges for each row or column** - the axis ranges vary across each pane in the view.
   - **Fixed** - specify the start and end values for the axis. Fixed axes are applied across all panes in the view.
3. You can also specify whether to automatically include zero. When the option to not include zero is selected, the axis range will adjust to just show the range of values in the data.

4. Click OK.

**Changing Axis Title and Scale**

1. Right-click the axis that you want to edit and select **Edit Axis**.

2. In the bottom left of the Edit Axis dialog box, optionally select one of the following options:
   - **Reversed** – select this option to reverse the order of values on the axis.
   - **Logarithmic** – select this option to use a logarithmic scale on the axis.

3. Click OK.

**Modifying Tick Marks**

You can specify how often the tick marks are displayed along the axis.

1. Right-click the axis you want to edit and select **Edit Axis**.

2. In the **Edit Axis** dialog box, select the **Tick Marks** tab.

3. For both Major and Minor tick marks, select from one of the following options:
   - **Automatic** - select this option to automatically show tick marks based on the data in the view.
   - **Fixed** – select this option to specify how often the tick mark should display and the starting value.
   - **None** – select this option to hide the tick marks completely.

4. Click OK.

**Copy Formatting to Other Worksheets**

1. Click the worksheet from which you want to copy formatting.

2. Select **Format > Copy Formatting**.

3. Click on the worksheet you want to paste the formatting into.
4. Select **Format > Paste Formatting**.

Note: This command does not copy manual sizing, zoom settings, or default label orientation.

**Drop Lines**

Drop lines are most useful for distinguishing marks and calling out their position in the view. For example, in a view that is dense with scatter marks, you can turn on drop lines to show the position of a particular data point.

When you add drop lines a line is extended from the marks to one of the axes. You can choose to show drop lines all the time or only when a mark is selected.

Tip: Drop lines are best for scatterplots.

**Add Drop Line**

1. Create the following view and right-click on the pane and select **Drop Lines > Show Drop Lines**.

2. Select a specific data point to verify drop lines appear.
**Highlight Marks**

Highlighting allows you to call attention to marks of interest by coloring certain marks and dimming others.

**Highlight using Color Legend**

1. On the color legend card menu, click the Highlight button at the top of the color legend or select Highlight Selected Items.

2. You can select an item in the color legend or a dataset in the view to verify the highlight.
Annotations

Use annotations to call out a specific mark, a specific point such as a value on the axis or a reference line, or an area such as a cluster of scatter marks.

Add a Mark Annotation

1. Right-click the view where you want to add an annotation and select Annotate.

2. Select one of the following types of annotations from the submenu:
   - **Mark** - select this option to add an annotation that is associated with the selected mark. This option is only available if a mark is selected.
   - **Point** - select this option to annotate a specific point in the view.
   - **Area** - select this option to annotate an area in the view such as a cluster of outliers or a targeted region of the view.

3. In the Edit Annotation dialog box, type the text you want to show in the annotation and click on the OK button.

4. The annotation that you just made will appear on the chart.
Positioning a Mark Annotation

After you add an annotation, you can move it around, resize it, adjust the line, and move the text.

- **To reposition the body**: Click and drag the body of the selected annotation to a new position.
- **To resize the body**: Click and drag the body resize handle left and right. The text and height are automatically adjusted to fit the width of the body.
- **To resize the line**: Click and drag the line resize handle.

Area Annotation

An area annotation is a way to highlight or call out an area in the view. As opposed to a single mark annotation, area annotations are commonly used to call out several marks.

- **To reposition the box**: Click and drag the box of the selected annotation to a new position.
- **To resize the box**: Click and drag one of the box resize handles.
- **To reposition the text**: Click and drag the center text handle to a new position.
- **To resize the text width**: Click and drag the right text handle left and right. The text height is automatically adjusted to fit the width.

Format Annotations

You can modify the text, body, and line for each annotation.

1. Select one or more annotations, right-click one of the selected annotations, and select **Format**. The Format window opens showing the relevant settings.
2. In the Format window, use the drop-downs to specify font properties, text alignment, line style, and shading.

Removing Annotations

1. Select one or more annotations to remove.
2. Right-click one of the selected annotations and select **Remove** or click the **Delete** key on your keyboard.

Labels

Labels are values shown next to each data point in a view. They can be value numbers like sales values, or they can be the child name or category next to each line. They can be turned on for all marks, selected marks, highlighted marks, the minimum and maximum values, or just the line ends in a line chart.

Displaying Labels for the Entire Worksheet

You can show and hide mark labels for the whole worksheet by clicking the **Show Mark Labels** button on the toolbar. Use the Label shelf drop-down control to specify font properties, alignment, when to show the label, and other options.
Showing and Hiding Individual Mark Labels

You can show and hide individual mark labels using the right-click context menus in the view.

1. Right-click the mark you want to show or hide a mark label.
2. On the context menu select Mark Labels and then one of the following:
   - **Automatic** - select this option to allow Tableau to turn the label on and off depending on the view and the settings in the Format window.
   - **Always Show** - select this option to show the mark label even when it would otherwise be hidden (based on the settings in the Format window).
   - **Never Show** - select this option to hide the mark label even when it would otherwise be shown (based on the settings in the Format window).

Moving Labels

1. Select the mark whose mark label you want to move.
2. Click and drag the yellow move handle to a new location.

**Tip:** It is not recommended to move label locations around if the user will be filtering the data a lot. As the data plots shift in location, the label will not.

Tooltip

Tooltips are additional data details that display when you rest the pointer over one or more marks in the view. Tooltips are specified for each sheet and can be formatted using the formatting tools along the top of the Edit Tooltip dialog box.
Add Tooltip

1. In the toolbar, select **Worksheet > Tooltip** or click on the **Tooltip** shelf under the marks card.
2. Modify the content in the **Edit Text** box. You can add dynamic field values by clicking on the **Insert** dropdown.

3. When you hover over a data point in the view, the tooltip will be shown.

### Module Summary

You should now be able to:

- Identify the various options to enhance your view and make interactive
- Apply basic formatting for fonts, alignment, shading, borders and lines
- Add annotation, labels, and tooltip to highlight data and facilitate analysis