Tableau Desktop User Guide

Publisher Role

Document Owner: UCLA Health – OHIA: Office of Health Informatics and Analytics
Update Date: 2/26/2016
Created Using: Tableau Version 9.1
Table of Contents

Table of Contents .................................................................................................................... 2

Preface ....................................................................................................................................... 6

The Purpose of This Training ................................................................................................. 6
Target Audience ................................................................................................................. 6
Instructor-led Exercise .......................................................................................................... 6
Training datasets .................................................................................................................. 6
How to Use This Training ................................................................................................... 6
Icons to Look For .................................................................................................................. 6

Module 8: Multiple Data Connections .................................................................................. 7

Module Objectives ............................................................................................................... 7
Understanding Data Connections .......................................................................................... 7
  Joins - Adding One Additional Table from the Same Data Source ...................................... 7
  Blending Data Overview .................................................................................................. 9
Module Summary .................................................................................................................. 13

Module 9: Parameters ........................................................................................................... 14

Module Objectives ............................................................................................................... 14
Parameters .......................................................................................................................... 14
  Creating Parameters ...................................................................................................... 14
Module 9 Exercise ............................................................................................................... 14
Module Summary .................................................................................................................. 17

Module 10: Advanced View Topics ..................................................................................... 18

Module Objectives ............................................................................................................... 18
Level of Detail ...................................................................................................................... 18
Radial Selection ................................................................................................................... 19
Analytics Pane ..................................................................................................................... 19
  Forecast Exercise: .......................................................................................................... 20
R Integration ......................................................................................................................... 21
Module Summary .................................................................................................................. 22

Module 12: Dashboards ......................................................................................................... 23

Module Objectives ............................................................................................................... 23
Dashboard Overview ........................................................................................................... 23
  Create Dashboard and Add Views ..................................................................................... 23
  Add Dashboard Objects .................................................................................................. 25
  Remove Dashboard Objects ............................................................................................ 26
Dashboard Layout ................................................................................................................ 26
  Add Layout Container ..................................................................................................... 26
  Remove Layout Container ............................................................................................... 26
  Formatting Layout Containers ....................................................................................... 26
Module 13: Saving, Sharing and Publishing ................................................................. 37

Module Objectives ........................................................................................................... 37
Saving Your Work ............................................................................................................. 37
   File Types ....................................................................................................................... 37
   Saving a Workbook ......................................................................................................... 38
   Saving a Packaged Workbook ....................................................................................... 38
   Saving the Data Source Connection ............................................................................ 39
   Saving View as Image ..................................................................................................... 40
   Printing .......................................................................................................................... 40
Sharing and Publishing .................................................................................................... 40
Tableau Server Overview ................................................................................................. 41
Publishing to Tableau Server .......................................................................................... 41
CoE Projects ..................................................................................................................... 41
Tableau Server Roles and Permissions ............................................................................ 42
   CoE Project ..................................................................................................................... 42
   CoE Restricted Project ................................................................................................. 42
Publishing Options ........................................................................................................... 43
   Showing and Hiding Worksheets on Server ................................................................. 45
   Schedules ......................................................................................................................... 45
   Specify Permissions ....................................................................................................... 45
   Adding Permissions ....................................................................................................... 45
   Publishing Capabilities ................................................................................................. 46
User Filtering for Specific Fields on the Server ............................................................... 47
   Create a User Filter ....................................................................................................... 47
Module Summary .............................................................................................................. 48

Module 14: Navigating Tableau Server ......................................................................... 49

Module Objectives ........................................................................................................... 49
Navigating Tableau Server ............................................................................................... 49
   Left Navigation ............................................................................................................... 49
   Actions ........................................................................................................................... 50
   Sort Options .................................................................................................................. 50
   Help .............................................................................................................................. 51
   Favorites ....................................................................................................................... 51
   User Preferences ......................................................................................................... 51
Module Objectives

Edit Workbooks
Working with Cards and Shelves
Navigating a Workbook or Dashboard on Tableau Server
Sharing Workbooks
Saving Customized Views
Comments
Tableau Server Workspace
Data Connection Window
Dimensions
Measures
Sets
Parameters
Toolbar

Actions
Navigating Views
Saving Edited Workbooks
Label Shelf
Shape Shelf
Size Shelf
Color Shelf
Pages Shelf
Box
Histogram
Pie Chart
Toolbar
Sets
Measures
Data Connection Window
Sharing Work
Workbook Options
Tab navigation and filters
- and 
-ions
Whisker Plot

Types of Shelves
Pages Shelf
Filters Shelf
Detail on Marks Card
Color Shelf
Size Shelf
Shape Shelf
Label Shelf
Edit Workbooks
Saving Edited Workbooks

Module 15: Mobile Application
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Editing in Mobile Application</td>
<td>70</td>
</tr>
<tr>
<td>Module Summary</td>
<td>70</td>
</tr>
<tr>
<td>Appendix A: Glossary</td>
<td>72</td>
</tr>
<tr>
<td>Appendix B: Mark Type Matrix</td>
<td>74</td>
</tr>
<tr>
<td>Appendix C: Keyboard Shortcuts</td>
<td>76</td>
</tr>
<tr>
<td>Appendix D: Functions Definitions</td>
<td>78</td>
</tr>
<tr>
<td>Appendix E: Operators</td>
<td>80</td>
</tr>
<tr>
<td>Appendix F: Tableau References</td>
<td>82</td>
</tr>
</tbody>
</table>
Preface

The Purpose of This Training

This user guide is for Tableau Desktop. It provides step-by-step instructions to create analytical and interactive reports and dashboards. The user guide gives you an overview of Tableau concepts as applied through a visualization exercise example.

Target Audience

The user guide primarily targets people who will be creating and publishing dashboards to Tableau Server.

Instructor-led Exercise

The instructions in the modules within this user guide are based on the in-class demonstration the instructor will walk-through. Steps should be used as a guideline and may vary once you have access and connection to the production environment post-training.

Training datasets

The examples in this user guide will utilize the following dataset:

1. Sample - Superstore (which we will be connected to through Tableau Server)

How to Use This Training

You can use this user guide in several ways. You can start at the beginning and go module-by-module as you learn the different topics within Tableau. You can also use this user guide as a reference by using the table of contents to jump to particular topics.

Icons to Look For

The following are specific icons to look for when reading:

Tip: The tip gives additional detailed information about a topic.

Note: The note denotes a caution about an aspect of the topic. It will not always be applicable to all situations; you should check whether it applies to you.
Module 8: Multiple Data Connections

Module Objectives

- Understand when to use multiple data connections
- Know how to add and remove a secondary connection

Understanding Data Connections

A workbook can contain different types of data connections. It can contain:
- Data from one table within a single source
- Data from multiple tables from the same source
- Data from different tables from different data sources with common fields in the different tables

The example used in the previous modules within the user guide leverages one table within a database. However, in most real-life scenarios, you will use data from multiple tables. This module focuses on how to add and work with multiple data connections.

Joins - Adding One Additional Table from the Same Data Source

Using the Sample - Superstore Subset (Excel).xlsx file included in your Tableau installation, we will load and join multiple tables of data.

Tip: To optimize performance, you should be connected live to a data source when adding tables.

1. Open the workbook Class Training – Superstore.
2. In the main toolbar, go to Data > ‘Name of Connection’ > Edit Connection
3. The Data Connection window will appear. Click and drag the Returns table into the data white space where Orders is

4. By default, the joins will be an inner join, click the double circles to modify the join properties

5. Select Left Join and ensure the two join IDs are accurate

6. Repeat steps 2-4 to join the People table to the Orders table

7. Select the Go to Worksheet to view the updated data structure. You will see new available fields from the two new tables
Note: If you are adding tables from an extract, you will receive a warning that filters will be cleared. If you click OK the data extract will be regenerated and may take some time depending on the number of rows you are importing. It is recommended you always connect live when adding tables and then extract your data.

Tip: The only way to achieve Unions in Tableau is to use the Custom SQL function.

Blending Data Overview

A workbook can contain multiple connections to multiple data sources. Each worksheet has a primary connection and can have several secondary connections. Common fields in the primary connection and the secondary connections link the data sources together.

Data blending should be used when you have related data sources that you want to analyze together in a single view.

Tableau will submit a separate query to each data source and return the aggregate of the results from the secondary data source(s). The results from the secondary data source are aggregated at the level of the common fields available between the data sources. This means we can only slice each measure (numeric field) by the common fields. It also means that only aggregate calculations are possible when combining fields from different data sources in a calculated field unlike joins which allow for row level calculations.
Adding a Secondary Connection (Adding Multiple Tables from Different Data Sources)

Each worksheet needs to have a primary data source. The primary data source is the connection that you first use in the view. After you drag fields into the view, the primary connection is marked with a blue check mark.

If you switch to another connection, you’ll notice that the Data window is marked with an orange color to indicate that you are using fields from this connection. The orange check indicates the secondary connection.

We are now going to load in the Sample - Superstore data set we have been using. Orders and Returns are the linking fields.

1. Open a workbook with your Sample – Superstore Orders.xlsx dataset with an Extract.
2. Select Data > New Data Source.
3. Select Microsoft Excel and select the Sample – Superstore Returns.xlsx file provided in the training material folder.
4. Load in the single table through an Extract connection type and save the Extract in the same folder as the .xlsx files.
5. Now you will see two data sources in the data sources card. Below in the dimensions field of the newly added data source you will see an icon indicating that the field has been linked between both sources.
6. To edit the relationships, select **Data > Edit Relationships**.

7. To manually add relationships, toggle to **Custom** and select **Add**.

8. Select **Order ID** from the primary data source column and **Order ID** from the secondary data source column.

9. Click **OK**.

10. The broken link icon will appear next to a Dimensions card. Click the icon to link the two fields.

11. Navigate back to the Orders (Primary Table) and drag **City** to the Row shelf.
12. Navigate to the Returns (Secondary Table) right click the **Returned** dimension and create a calculated field as below:

```
COUNT({[Returned]})
```

13. Click OK. Drag **Returned** to the columns field and repeat for Filters. Exclude Nulls. Double click and **Returned #** and the result is number of returns per city.

**Tip:** To determine whether data can be blended effectively, drag the dimensions from the primary data source into a text table on one sheet. Then on another sheet drag the same fields from the secondary data source into a text table. If the two tables match up, then the data is most likely going to blend correctly.

**Removing a Secondary Connection**

1. Remove all the secondary dimensions and measures that are used in the chart.
2. Right-click the secondary connection at the top of the Data window and select **Close**.
3. You will get a warning that closing the connection will remove all fields from that data source. Click Yes.

Module Summary

You should now be able to:

- Understand when to use multiple data connections
- Know how to add and remove a secondary connection
Module 9: Parameters

Module Objectives

- Understand parameters and how to create them

Parameters

Dynamic values that can replace constant values in calculations and can serve as filters. For example, you might have a calculated field that returns True if revenues are greater than $500,000, and otherwise returns False. Using a parameter, you can replace the constant value of $500,000 in the calculated field with a parameter than you can change dynamically using the Parameter control.

Creating Parameters

1. In the Data window, right-click a field to base the parameter on and select Create Parameter.
2. In the Create Parameter dialog box, type in a name.
3. Specify the data type for the values it will accept. Parameters can be a float (non-integer number), integer, string (text), Boolean (true/false), date, or date & time.
4. Specify a current value. This is the default value for the parameter.
5. Specify the display format to use in the parameter control.
6. Specify how the parameter will accept values. You can select All, List, or Range.
   - **All** – the parameter control is a simple type in field.
   - **List** – the parameter control provides a list of possible values for you to select from. You must specify the list of values.
   - **Range** – the parameter control lets you select values within a specified range. You must specify a minimum, maximum, and step size.

**Note:** The availability of the option is determined by the date type in Step 3.

Module 9 Exercise

In this exercise you will create a parameter to set a target for the net profit for child name resources. Use the parameter in a calculated field to color and encode the various product sub-categories depending on if they are over or under the target.

1. Create the following view for City and Sales
2. In the measures data box, right-click and select **Create Parameter** and name it **Sales Target**. Set the default value to **15,000**, Change the Data Type to **Integer** and allow **all values**.

3. Notice the new parameter created in the Parameters card.

4. Right-click the parameter to select **Show Parameter Control**. This creates a box to the right of the view to allow you to toggle the parameter values.
5. Right-click on the bar chart axis to add a reference line of the Order Target

6. Set the value of the reference line to the parameter we created. Change the line color to Red to stand out more

7. Change the value of the Sales Target in the parameter control box to 20,000 and notice the reference line shift
8. Create a calculated field to compare the Sales to the Sales Target. This will create two values, Over and Under

```sql
IF SUM([Sales]) > [Sales Target] THEN 'Over'
ELSE 'Under'
END
```

9. Click and drag the new calculated field into the color shelf, and notice the bar colors changed based on the Sales Performance

Module Summary

You should now be able to:

- Understand parameters and how to create them
Module 10: Advanced View Topics

Module Objectives

- Apply Level of Detail to calculations
- Use distance measurements to select data in Map Views
- Understand the Analytics Pane in Tableau Desktop
- Integrate Tableau with R

Level of Detail

Level of detail expressions, also called “LOD”, allow for the creation of calculations at a level of detail other than the view level. As an example, LOD allows for the comparison of current sales to average total sales, where the sales number are at different granularity levels.

A level of detail expression is entered as a calculated field in Tableau and has the following structure:
{(FIXED | INCLUDE | EXCLUDE) <dimension declaration> : <aggregate expression>}

Example: { FIXED [Region] : SUM([Sales]) }

- {} : The entire level of detail expression is enclosed in curly braces.
- FIXED | INCLUDE | EXCLUDE:
  - FIXED level of detail expressions compute values using the specified dimensions without reference to any other dimensions in the view. They also ignore all the filters in the view other than context filters, data source filters, and extract filters.
  - INCLUDE level of detail expressions compute values using the specified dimensions in addition to whatever dimensions are in the view. They are most useful when including a dimension that is not in the view.
  - EXCLUDE level of detail expressions subtract dimensions from the view level of detail. They are most useful for eliminating a dimension in the view.

- <dimension declaration>: Specifies one or more dimensions to which the aggregate expression will be set. Use commas to separate dimensions.
- <aggregate expression>: The calculation performed to define the target dimensionality.
Radial Selection

Tableau’s radial tool allows a user to measure the area on a map that they want to select. To use the Radial tool, hover over the arrow on the map toolbar and click the Radial tool button.

Then select the area on the map that you want to measure from and drag across the view. The Radial tool displays the radius distance and selects the marks that are within the circle.

Analytics Pane

The Analytics pane provides quick access to common analytical features in Tableau. A user can drag reference lines, box plots, trend lines, forecasts, and other analysis tasks into a view from the Analytics pane.
Forecast Exercise:

1. Create the simple Sales trend line below, with a Continuous Month Order Date.

2. Create a forecast by either dragging forecast from the Analytics Pane into the view, or right-clicking in the view and selecting Show Forecast.
3. Change the forecast length to be two years, by right-clicking the view > Forecast > Forecast options.

![Forecast Options](image)

4. Check for the forecast quality by right-clicking the view > Forecast > Describe Forecast.

![Describe Forecast](image)

5. Remove the Forecast.

**R Integration**

R is a popular open-source environment for statistical analysis. Tableau Desktop can connect to R through calculated fields and take advantage of R functions, libraries, and packages.

- In order to run R scripts in Tableau, an R Server instance needs to be available. If R is installed on a computer, open the R editor and install the Rserve package. Run the command `Rserve()` to start the server.
- Switch back to Tableau and select **Help ➔ Settings and Performance ➔ Manage R Connections**.
- Enter your R Server connection information in the window and click on **OK**.
- Open a new or select an existing sheet and create a calculated field.
- Tableau has four functions for running R scripts. The script that should be selected will depend on the output of the R script. For example, if the R script returns an integer value than **SCRIPT_INT** should be chosen.

```plaintext
Tableau functions for R have the following structure:
SCRIPT_INT(<string>, <expression1>, ...)  
  o String: This contains the R code surrounded by quotes. R function parameters that reference Tableau data should be specified as .arg# (e.g., .arg1) in the R script.  
  o Expression: If an argument is passed to R, the Tableau field containing the desired data can be specified here. Tableau passes the first expression to .arg1, second expression to .arg2, etc.
```

**Module Summary**

You should now be able to:

- Create Level of Detail calculations
- Use distance measurements to select data in Map Views
- Understand the Analytics Pane in Tableau Desktop
- Integrate Tableau with R
Module 12: Dashboards

Module Objectives

- Create a dashboard and add views
- Rearrange the dashboard layout
- Edit view titles and add a dashboard title

Dashboard Overview

A dashboard is a collection of several worksheets and supporting information shown in a single place so you can compare and monitor a variety of data simultaneously, instead of flipping through each worksheet.

Similar to worksheets, dashboards are shown as tabs at the bottom of the workbook and update with the most recent data from the data source. When you create a dashboard, you can add views from any worksheet in the workbook. You can also add a variety of supporting objects such as text areas, web pages, and images. From the dashboard, you can format, annotate, drill-down, edit axes, and more.

Each view you add to the dashboard is connected to its corresponding worksheet. That means when you modify the worksheet, the dashboard is updated and when you modify the view in the dashboard, the worksheet is updated.

Create Dashboard and Add Views

You can create a dashboard in much the same way you create a new worksheet. After you create a dashboard you can add and remove views and objects.

1. Select Dashboard > New Dashboard or click on the Dashboard Icon at the bottom of the Tableau Workbook. A new tab for the dashboard is added along the bottom of the workbook after a New Dashboard is created.

2. When you open a dashboard the Dashboard window replaces the Data window on the left side of the workbook. The Dashboard window lists the worksheets that are currently in the workbook. As you create new worksheets, the Dashboard window updates so you always have all worksheets available when adding to a dashboard.
3. Click and drag the preferred worksheets from the Dashboard window to the dashboard on the right.

4. You can drag worksheets around by clicking on a view and grabbing the top bar on a view.

Tip:
- After a view is added to the dashboard, the worksheet is marked with a check mark in the Dashboard window. Also, any legends or quick filters that are turned on for the sheet are automatically added to the dashboard.

5. You can add additional views as floating views in order to conserve real estate by selecting **Add new sheets and objects as Floating**. Tiled objects are easier to maintain, but floating objects allows you to overlay objects on top of others.
6. You can resize the floating object and place it wherever you’d like it to be within the Dashboard.

7. You can edit the title of a particular view on a dashboard by right-clicking on the title.

Add Dashboard Objects

A dashboard object is an area in the dashboard that can contain supporting information that is not a Tableau view.

1. Click and drag or double-click on a dashboard object.

- **Horizontal / Vertical** – These two containers allow you to store multiple items in within a shared space. This is convenient for maintenance and sizing of similar items such as filters and charts.
• **Text** - The text object allows you to add a block of text to the dashboard. This is useful for adding captions, descriptions, and even copyright information. The text object will automatically resize to best fit where you place it in the dashboard. However, you can also resize the text area manually by dragging the edges of the text object.

• **Image** - You can add static image files to the dashboard. For example, you may want to add a logo or descriptive diagram. When you add an image object, you are prompted to select an image from your computer. You can also type a URL for an image that is hosted online.

• **Web Page** - The web page object allows you to embed a web page into your dashboard so you can combine your Tableau content with information from other applications.

• **Blank** - The blank object lets you add blank areas to your dashboard so you can get the layout just right. Resize the blank object by clicking and dragging the edges of the area. Useful for use with tiled objects/dashboards.

**Remove Dashboard Objects**

1. Right-click the worksheet in the Dashboard window.
2. Select **Remove** from Dashboard.

**Dashboard Layout**

**Add Layout Container**

One of the objects available is a layout container that creates an area in the dashboard where objects automatically adjust their size and position based on the other objects in the container.

1. Drag a horizontal or vertical layout container to the dashboard.
2. Add sheets and objects to the layout container. As you hover over the layout container, an arrow indicates how the objects will flow within the container.
3. Verify the objects move and resize to your liking.

**Remove Layout Container**

When you remove a layout container, it and all of its contents are deleted from the dashboard.

1. Select an object in that layout container you want to delete.
2. Open the drop-down menu in the upper right corner of the selected object and select **Select Layout Container**.
3. Open the drop-down menu for the selected layout container and select **Remove from Dashboard**.

**Formatting Layout Containers**

You can specify a border style for layout containers so that you can visually group objects in the dashboard.
1. Open the drop-down menu for the layout container you want to format and select **Format Container**.

2. In the Format window, specify a line style, thickness, and color for the border.

**Rearrange Dashboard Objects**

You can rearrange the parts of a dashboard using the move handle at the top of a selected view, legend, or quick filter.

1. Select the view, legend, or quick filter that you want to move.

2. Click and drag the move handle at the top of the selected item to a new location.

3. Drop the dashboard element in a new location. As you drag the element around the dashboard area, a black bar highlights the available places you can drop it.

**Dashboard Transparency**

The backgrounds of legends, text boxes, images and other dashboard objects can be set to varying degrees of transparency.

1. Right click on the object you want to change the shading and click on format. For example, for legends, click on **Format Legends**

2. Under body drop down on shading, select color and move the tick mark to change the transparency percentage

**Setting Dashboard Size**

By default, the views and objects in a dashboard automatically scale to fill the entire window. That means that the size of the dashboard can vary from machine to machine, depending on the screen resolution and the size of the application window. You can specify a specific size for the dashboard, which ensures a consistent layout when you share the dashboard with others and lessens the workload of Tableau Server’s rendering process. The size of the dashboard is displayed at the bottom of the Dashboard window.

1. Dashboard size can be set at the bottom left window

2. Select one of the following behaviors:

   - **Automatic** - the dashboard automatically resizes to fill the application window. This is the default behavior. *(Not recommended)*
• **Exactly** - the dashboard always remains a fixed size. If the dashboard is larger than the window the dashboard becomes scrollable. *(Recommended)*

• **Range** - the dashboard scales between the specified minimum and maximum sizes, after which it scroll bars or white space will display.

• **At Least** - the dashboard automatically resizes to fill the application window, but will not scale smaller than a specified minimum size. When viewed smaller, scroll bars will display.

• **At Most** - the dashboard automatically resizes to fill the application window, but will not scale larger than the specified maximum size. When viewed larger, white space will be added.

3. If you select any option other than Automatic, you must define a size. Select one of the following types of sizes:

   • **Standard** - select from a list of common sizes, such as 800 x 600.

   • **Custom** - type a custom width and height into the text boxes. By default, these text boxes are filled with the dashboard’s current width and height.

4. When finished, click **OK**.

**Create a Dashboard**

**Prepare views for dashboard**

- Table

- Coaches by State

**Building the Layout**

1. Create a new blank Dashboard titled **Sales Dashboard**

2. Drag a **text** object to serve as a header and shade the background

3. Drag an **image** object to add a logo to the dashboard

4. The rest of the objects can be added by clicking on the sheet name on the left hand side and dragging objects into the blank space. Ensure these are coming in as floated objects

5. If using quick filters in any visualizations, place them in layout containers to ensure uniform alignment.

**Interactive Dashboards using Actions**

Tableau enables dashboards to be interactive by using actions.

- Filter actions

- Highlight actions

- URL action
Create a Filter Action

1. Select Dashboards > Actions.

2. In the Actions dialog box, click Add Action and then select Filter.

3. Use the drop-down list to select a source sheet or data source.

4. Select how you want to launch the action.
   - Hover – rest the pointer over a mark in the view to run the action. Best for highlight and filter actions within a dashboard.
   - Select – click on the mark in the view to run the action. Works well for all types of actions.
   - Menu – right-click a selected mark in the view and then select an option on the context menu. Works best for filter and URL actions.

5. Use the second drop-down list to select a target sheet.

6. Specify what to do when the select is cleared in the view.
   - Leave the filter – leaves the filter on the target sheets. The target views in the dashboard will show the filtered results.
   - Show all values – changes the filter to include all values.
   - Exclude all values – changes the filter to exclude all values. This option is useful when you are building dashboards that only show some sheets if a value in another sheet is selected.

7. Set up one or more filters to specify the data that you want to show on the target sheets. You can filter on All Fields or define filters on Selected Fields.

8. If you are defining filters for specific fields click Add Filter.

9. In the Add Filter dialog box, select a source and target data sources and fields. When you run the action from a specific mark on the source sheet, a filter is added to the target sheet that only includes values for the target field that match the values of the source field.

10. Click OK three times to close the dialog boxes and return to the view.
Create a Highlight Action

1. Select Dashboard > Actions.

2. In the Actions dialog box, click Add Action and then select Highlight.

3. In the Add Highlight Action dialog box, type in a name for the action. Try to make it as descriptive as possible.

4. Use the drop-down list to select a source sheet or data source. If you select a data source or a dashboard sheet you can further select sheets within them.

5. Select the fields you want to use for highlighting.
   - Selected Fields – marks in the target sheet are highlighted based on select fields. For example, highlighting using the Child Name will result in an action that highlights all marks in the target sheet that have the same Child Name as the selected mark in the source sheet.
   - Dates and Times – marks in the target sheet are highlighted when their date and time match those of the marks selected in the source sheet. All dates and time fields are considered when determining a match.
   - All Fields – marks in the target sheet are highlighted when they match the marks selected in the source sheet. All fields are considered when determining a match.

6. Click OK two times to close the dialog boxes and return to the view.

Create a Color Legend Highlighting Action

The color legend highlighting enables the marks associated with the selected items in the color legend to be colored while all other marks are gray.

1. Click on the Highlight button at the top of the color legend to enable the highlighting action.

2. Select an item in the color legend or the Tableau chart to validate highlighting action is enabled.

Create a URL Action

A URL action is a hyperlink that points to a webpage, file, or other web-based resource outside of Tableau.

1. Select Dashboard > Actions.

2. In the Actions dialog box, click Add Action and then select URL.
3. In the Add URL Action dialog box, specify a name for the link. It is best to provide a name descriptive of the action.

4. Use the drop-down list to determine the source sheet or data source.

5. Select the fields you want to use for highlighting.
   - Hover – rest the pointer over a mark in the view to run the action. Works best for highlighting and filter actions within a dashboard.
   - Select – click on a mark in the view to run the action. Work well for all types of actions.
   - Menu – right-click a selected mark in the view and then select an option on the context menu. Best for filter and URL actions.

6. Specify the URL.

7. Click OK twice to close the dialog boxes and return to the view.
Dashboard Exercise

1. Create the map showing sales by state like the below view.

   Detailed Directions:
   1) **Double click** on State from the data pane. This will automatically bring Longitude and Latitude into the view.
   2) Drag Sales to color on the marks card. Edit the colors as you wish
   3) Name the worksheet **Sales by State**.

2. Create a scatterplot showing sales and profit by product like the below view.

   Detailed Directions:
   1) Drag Sales to the **Columns** shelf and Profit to the **Rows** shelf.
   2) Drag Segment to the **Color** shelf in the Marks card.
   3) Drag Product Name to **Detail** in the Marks card or directly into the view (scatterplot).
   4) Name the worksheet **Sales and Profit by Product**.
3. Create a bar chart showing both Sales and Profit by Customer.

Detailed Directions:
1) Drag Customer Name to the Rows shelf.
2) Drag Sales to the Columns shelf.
3) Drag Profit to the view and drop it on top of the Sales axis until you see the below double ruler and + icon to create a Combined Axis Chart.

4) The Measure Names and Measure Values fields will appear on your view.
5) Drag Measure Names to the Color shelf on your Marks card. Edit the colors as you wish.
6) Name the worksheet Customer Details.
4. Bring all worksheets into the dashboard like below.

5. Rename the dashboard **Sales and Profit Dashboard**.

6. Show Dashboard by going to **Dashboard > Show Title**.

7. Move the color legends to the corresponding view. Do this by using the arrow drop down on the top right corner of the legend and choose **Floating**.

8. Create a **filter action** for the Sales by State worksheet, to filter the rest of the worksheets in the dashboard.
9. Create a **filter action** for the Sales and Profit by Product worksheet only to the Customer Details, making sure that if the selection is cleared, it will **exclude all values**.

![Filter Action](image)

10. Use the action filters to make sure the filter actions work properly. For instance: Select a state, select a mark or lasso several marks on your scatterplot, and then view the customer names. Then unselect the scatterplot marks and your Customer worksheet should no longer be viewable, since it’s excluding all values.

11. **Create a URL action** to search the Customer’s name on google with the **menu** option.

![URL Action](image)

12. **Test URL action** by clicking on a Customer Name and viewing the URL action in the tooltip.

![Customer Details](image)
13. Edit worksheet titles similar to below to allow for more straightforward use.

Module Summary

You should now be able to:

- Create a dashboard and add views
- Rearrange the dashboard layout
- Edit view titles and add a dashboard title
Module 13: Saving, Sharing and Publishing

Module Objectives

- Identify the various options for sharing a workbook
- Publish workbook to Tableau Server
- Publish data source to Tableau Server

Saving Your Work

Tableau provides three methods for saving your work:

- **Workbooks** – Saves all open worksheets
- **Packaged Workbooks** – Saves the workbook along with all referenced local file data sources and images into a single file
- **Bookmarks** – Saves the current worksheet

File Types

You can save your work using several different Tableau specific file types: workbooks, bookmarks, packaged data files, data extracts, and data connection files. Each of these file types is described below.

<table>
<thead>
<tr>
<th>Term</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Workbooks</td>
<td><img src="image" alt="twb" /></td>
<td>Tableau workbook files have the .twb file extension. Workbooks hold one or more worksheets and dashboards. You can save a workbook via the toolbar path <strong>File &gt; Save As.</strong></td>
</tr>
<tr>
<td>Bookmarks</td>
<td><img src="image" alt="tbm" /></td>
<td>Tableau bookmark files have the .tbm file extension. Bookmarks contain a single worksheet and are an easy way to quickly share your work. You can save a bookmark via the toolbar path <strong>Window &gt; Bookmark &gt; Create Bookmark.</strong></td>
</tr>
<tr>
<td>Packaged Workbooks</td>
<td><img src="image" alt="twbx" /></td>
<td>Tableau packaged workbooks have the .twbx file extension. Packaged workbooks contain a workbook along with any supporting local file data sources and background images. This format is the best way to package your work for sharing with others who don’t have access to the data. You can save a workbook via the toolbar path <strong>File &gt; Save As.</strong></td>
</tr>
<tr>
<td>Term</td>
<td>Button</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>--------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Data Extract Files</td>
<td></td>
<td>Tableau data extract files have the .tde file extension. Extract files are a local copy of a subset or entire data source that you can use to share data, work offline, and improve database performance. You can save the extract via the toolbar path <strong>Data &gt; Data Extract</strong>.</td>
</tr>
<tr>
<td>Data Connection Files</td>
<td></td>
<td>Tableau data connection files have the .tds file extension. Data connection files are shortcuts for quickly connecting to data sources that you use often. You can save the data connection files via the toolbar path <strong>Data &gt; Data Connection &gt; Export</strong>.</td>
</tr>
</tbody>
</table>

**Saving a Workbook**

Workbooks hold the work you create and consist of one or more worksheets. Each worksheet contains a particular view of your data. When you save your workbook, the default location will be **My Tableau Repository > Workbooks** and only you will have access to them.

![Workbook Folder Structure](image)

There will be two folders on the Citrix environment which is where you will save your workbooks. The Development folder is the location to save your workbooks that are still in development or you would like to co-develop with your CoE. Once the development is finished and it is ready to be published, save it to the Published folder and then publish your content.

![Development to Published](image)

**Saving a Packaged Workbook**

If you will be sharing the workbook with someone who does not have access to the referenced resources, you will need to save as a packaged workbook. Packaged workbooks contain the workbook along with a copy of any local file data sources and background images. This will be necessary when publishing to the Tableau Server.

1. Select **File > Save As**. *(Local Disc ©/Documents/My Tableau Repository)*
2. Specify a file name for the packaged workbook in the **Save As** dialog box.
3. Select Tableau Packaged Workbooks on the Save as type drop-down list.
4. Click Save. Tableau saves the file with the .twbx extension.

Saving the Data Source Connection

If you connect to the same data source multiple times, you may want Tableau to remember the connection so that you can quickly reconnect the next time.

When you connect to a data source for the first time, Tableau asks you if you want to remember the connection by saving a copy in your repository. This copy acts as a shortcut allowing you quickly connect without opening the connection dialog box.

The connection is saved as a Tableau Data Source (TDS) file. Each TDS file references one data source, and stores information about the data source type and location, and any custom fields you have created. TDS files do not store data, workbooks, or worksheets.

There are two different ways to save Data Source Connections.

1. Save Data Source Connection in Tableau Desktop

2. Save Data Source Connection in Tableau Server

Save Data Source Connection in Tableau Desktop

1. Select Data > Data Connection Name > Add to Saved Data Sources.

2. In the Export Connection dialog box, type in a file name.

3. Click Save. (Local Disc ©/Documents/My Tableau Repository)
Saving View as Image

You can save any part of a worksheet as an image to share with your coworkers who do not have access to Tableau, or if you want to include it in a Keynote presentation or document.

1. Select Worksheet > Export > Image from the File menu.
2. In the Export Image dialog box, select the contents you want to include in the image and the legend layout if you are including a legend. When finished click Save.
3. In the Save Image dialog box, navigate to where you want to save the image file and type a file name into the text box. Select a file format from the Save as type drop-down menu. When finished click Save.
4. In most cases, paste the image as an Enhanced Meta File to get the best presentation quality.

Printing

1. Select File > Page Setup to determine the layout, print scale, page orientation, and captions.
2. Go to File > Print.
3. Click OK.

You can publish one or more views to PDF by selecting File > Print to PDF.

Sharing and Publishing

You can share your worksheets, workbooks, or dashboards with colleagues who either have or don’t have access to the data source.

- To share your views and charts with someone who doesn’t have access to the database nor a license, you can save as PDF or export as image. Simply go to File > Print to PDF.
- If you want to share dashboards with someone that has a license to Tableau Server, publish to the Tableau Server by following the next steps.
Tableau Server Overview

Tableau Server is where you and others can share views of your data within UCLA Health. You can publish workbooks and data sources to the server, as well as open workbooks and data sources from the server.

**Note:** You must have the right permissions to publish to the server for designated people to view your data files.

Publishing to Tableau Server

Once you have created and saved a workbook, you can publish it to the server.

1. Select **Server > Publish Workbook...**

Type the following into the Tableau Server Login dialog box and click on **Connect**:

- **Server:**
  - Publishing to Training: http://bsdtableau02
  - Publishing to AdHoc: TBD

Type in the following authentication information:

- **User Name:** UCLA Health Network User ID
- **Password:** UCLA Health Network Password

2. Click **Sign In**.

3. In the **Project** dropdown field of the Publish Workbook to Tableau Server dialog box, select a Project to publish the workbook into. When deciding which project to publish to, follow the below process:

CoE Projects

When you are ready to publish, your CoE may have two available projects to you. View the diagram below to understand the differences in these particular projects.
# Tableau Server Roles and Permissions

## CoE Project

<table>
<thead>
<tr>
<th>Role</th>
<th>Permissions</th>
</tr>
</thead>
</table>
| CoE Tableau Administrator| The CoE Tableau Administrator is a conceptual role, not a Tableau role. A CoE Administrator is a selected Project Leader (see below) in Tableau who will act as an administrator for a CoE’s Project(s) in Tableau to  
  - Ensure space requirements are met  
  - Ensure workbook performance testing is done  
  - Ensure files on Citrix and Tableau Server are managed (delete old files, ensure no duplicate files exist, follow file naming conventions, etc.) |
| Project Leader           | Tableau users with this role can view, open, and edit all CoE published content on Tableau Server from Tableau Desktop. Project Leader is the only role that can download content.  
  - Project Leaders also have all Publisher, Interactor, and Viewer role functionality. |
| Publisher                | Publishers can publish, view and interact with all CoE published content on Tableau Server (hide, exclude, sort, and filter).  
  - Publishers also have all Interactor and Viewer role functionality |
| Interactors              | Interactors can filter the published content and view automatically updated data  
  - Interactors also have Viewer role functionality |
| Viewers                  | Viewers can view and export as image & PDF all CoE published content, add comments and view comments. |

## CoE Restricted Project(s)

<table>
<thead>
<tr>
<th>Role</th>
<th>Permissions</th>
</tr>
</thead>
</table>
| Project Leader  | Project Leaders will be the only publisher(s) for this project.  
  - Project Leaders also have all Publisher, Interactor, and Viewer role functionality for this project.  
  - A Project Leader for a CoE’s restricted project(s) should also be a Project Leader in the non-restricted project. The reverse is not required. |
Content Developers (Interactors on Server) | Content developers can create content in Tableau Desktop, however when it’s time to publish, they will notify their Project Leader. Once on Tableau Server, they will become interactors.

Interactors | Interactors can filter the published content and view automatically updated data

### Publishing Options

![Image of Publishing Options dialog box]

**Tip:** A project is like a folder that can contain workbooks and data sources. All workbooks must be published into a project.

4. In the **Name** text field, type a name for the workbook into the Name text box or use the drop-down list to select an existing workbook on the server.

**Note:** When you publish using an existing workbook name, the workbook on the server is overwritten with your workbook.

5. In the **Add Tags** text field, type one or more keywords that describe the workbook into the Tags text box. Tags help you and others find related workbooks when browsing the server. Each tag should be separated by either a comma or a space.

6. In the **View Permissions** section in this dialog box, you can view specific permissions for this workbook based on the defined security groups and Tableau user roles. Publishers can alter permissions per workbook that will override the AD group permissions, but this is **not recommended**.

7. In the **View to Share** section in this dialog box, select the sheets and dashboards that you want to publish to the Tableau Server. Any sheets that are not selected are hidden on the server.

8. In the **Options** section in this dialog box, there are two checkboxes that you can select:
• **Show Sheets as Tabs:**
  - When this option is checked and there are multiple sheets to publish, the multiple sheets are shown as tabs linking them together in published dashboard.
  - When this option is not checked and there are multiple sheets to publish, the sheets are published individually. As a result, the sheets published within the dashboard have to be accessed one by one by navigating back to the grid/list view on the server.

• **Show Selections** - When this option is selected, any selections you have made in the workbook will be published to the server.

9. The **Scheduling & Authentication** button allows you to specify when the **Extract Schedule** and **Authentication** for viewing the dashboard.

• **Extract Schedule**: This selection specifies the frequency to refresh the data in the dashboard. **This option should be selected.** For additional information see the Schedules section within this module.

• **Authentication**: This option allows you to specify the authentication type for how users will view the data source within your published dashboard. This option is not applicable to enterprise wide data sources as these data sources are already authenticated by Windows.
  - **Embedded Password**: The embedded password option embeds your login credentials with this published dashboard. By default whomever you give permission to access this dashboard can view the data without entering their login credentials. This is the default selection and this is option that you should select.
  - **Prompt User**: This option will prompt the users who you give permission to access to enter his login credentials in order to see the data in the dashboard.

10. Decide whether to embed user names and passwords so server users don’t have to have an account on the database to see the views.

11. It is better to have an extract associated with your publishing dashboard. This way, when you set a schedule time, the server will refresh the data in the dashboard based on this time.

12. When finished, click **Publish**.
Showing and Hiding Worksheets on Server

By default, when a workbook is published to the server, all sheets can be viewed by all users. If you have Publisher permissions, you have the option to hide specific worksheets so they are not accessible on the server. However, hidden sheets can still be accessed when the workbook is opened from the server using Tableau Professional if a user has the ability to open the workbook form the server.

Showing and hiding worksheets is useful when you want to publish a complete dashboard without publishing the worksheets that make up the dashboard. Only the dashboard will show on the server.

Schedules

When you publish workbooks that connect to extracts you can schedule the extracts to be refreshed automatically. That way you don’t have to republish the workbook every time the underlying data has updated and you can still get the performance of a data extract.

A user needs to have proper permission rights to add a workbook to a schedule. If this option has been enabled, a Schedules & Authentication button shows in the publish dialog when you are publishing a workbook that connects to a data extract.

1. In the Scheduling & Passwords dialog box, select a schedule to add the workbook to. Custom schedules can be created by the server admins.

2. All data sources that require authentication must have an embedded password so that the extract can be refreshed. This includes data sources that are not extracts.

Specify Permissions

When you publish a workbook, you have the option to specify permissions both for groups and specific users. Permissions allow or deny access to the workbook and its contained views on the server.

Note: By default the permissions are set based on security group membership. It is not recommended to modify these when you publish. If workbook permissions are set, these will override AD group level permissions.

Adding Permissions

1. In the Publish Workbook to Tableau Server dialog box, click the Add button in the bottom left corner.
2. In the Add/Edit Permissions dialog window, find the name of the user or group that you want to authorize to have access to this dashboard.

3. For the selected user or group name, you can specify the role (Viewer, Interactor, or Editor) or you can create a Custom role by customizing the user or group’s access to the publishing dashboard.

4. Click OK.

5. You may also edit or remove permissions.

### Publishing Capabilities

<table>
<thead>
<tr>
<th>Capability</th>
<th>Ability to…</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>View the worksheets on Tableau Server</td>
</tr>
<tr>
<td>Write</td>
<td>Overwrite the workbook.</td>
</tr>
<tr>
<td>Delete</td>
<td>Remove the workbook</td>
</tr>
<tr>
<td>Filter</td>
<td>Modify quick filters, keep only filters, and exclude</td>
</tr>
<tr>
<td>Add Comment</td>
<td>Add comments to the views in the workbook</td>
</tr>
<tr>
<td>View Comments</td>
<td>View the comments associated with the views in the workbook</td>
</tr>
<tr>
<td>View Underlying Data</td>
<td>View the underlying data for the worksheets in the workbook.</td>
</tr>
<tr>
<td>Export Image</td>
<td>Export each worksheet as an image.</td>
</tr>
<tr>
<td>Capability</td>
<td>Ability to...</td>
</tr>
<tr>
<td>--------------------</td>
<td>-------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Export Data</td>
<td>Export the data to a text file.</td>
</tr>
<tr>
<td>Download File</td>
<td>Open the workbook from the server using Tableau Professional.</td>
</tr>
<tr>
<td>Share Customized</td>
<td>Share a customized view, making their changes public.</td>
</tr>
<tr>
<td>Move</td>
<td>Move workbooks between projects.</td>
</tr>
<tr>
<td>Set Permissions</td>
<td>Specify permissions for the workbook and all of the contained views.</td>
</tr>
</tbody>
</table>

**User Filtering for Specific Fields on the Server**

User filtering is a special kind of filter that allows you to limit the data any given person can see in a published view based on a specific field.

**Create a User Filter**

1. Select **Server > Create User Filter** and then select a field that you want to filter on.

   **Tip:** To create a User Filter on the dashboard worksheet, select a view first.

2. Log into Tableau Server.
3. In the User Filter dialog box, type a **Name** for the set of rules you are creating.
4. Select a user or group in the list on the left and the values he can see.
5. On the right, select the members of the field that the selected users are allowed to see. Repeat this process as necessary until everyone is assigned the correct set of members.

6. Click OK.

Module Summary

You should now be able to:

- Identify the various options for sharing a workbook
- Publish workbook to Tableau Server and specify permissions
Module 14: Navigating Tableau Server

Module Objectives

- Log into Tableau Server and navigate the site
- Open a workbook and interact with a dashboard on Tableau Server
- Share and save customized views on Tableau Server
- Customize user settings
- Editing Published Workbooks

Navigating Tableau Server

When you first log into Tableau Server, you see a navigation area on the left side of the page and a list of projects to which you have been given permission by the Tableau Project Leader.

Training Server: http://bsdtableau02

Left Navigation

The navigation area helps you browse the projects, workbooks, views, and data sources on the server.

- **Projects** – Projects are a way to organize Tableau workbooks, much like folders. Only the Tableau Server Administrator has the permission to add, remove, or modify projects.
- **Workbooks** – You can view either all the workbooks or filter them by date, project, or publisher. The workbooks accessible for you will be based on the permissions given by your Tableau Project Leader.
- **Views** – You can either view all workbooks that you’ve been given permission to, or view workbooks by date, project, publisher, or by tag.
- **Data Sources** – Lists out the Data Sources, the type of source system, publisher, date modified, and project name. If the proper permission is granted, Publishers and Web Publishers can use published Data Sources to create and publish workbooks.
- **Filters** – Allows users to search for objects and content in Projects, Workbooks, Views, and Data Sources sections.
• **Favorites** – Lists out the views and dashboards that have a star associated with them.

• **Recently Used** – Lists out the workbooks or dashboards that you recently opened.

**Actions**

When you select a Project and select a worksheet or workbook, there are several actions that appear only if you have permission to do so by the Tableau Project Admin or if you created your own views.

• **Delete** – Ability to delete workbook/worksheet/dashboard from Tableau Server.

• **Permissions** – Ability to edit and modify permissions.

• **Move** – Ability to move the file to another project.

• **Tag** – Ability to add tags to particular file.

• **Tabs** – Ability to show or hide tabs

• **Scheduled Tasks** – Ability to delete, edit priority, edit schedule, and run a workbook

• **Download** – Ability to download workbook to local machine

**Sort Options**

When you select a Project, you can sort the files within that Project to help you find files easier. You can sort by file name, project, sheets, date last modified, publisher name, and size of file.
Help
The dropdown menu for Help provides quick link to help topics such as User Lists, Search Content, Store Favorites, Schedule a Refresh, and edit and Create Views. You can always use the search box to find a specific file.

Favorites
When working with Worksheets or Dashboards you frequently visit, you can add the object to your favorite section by clicking on the star icon to the left of the Worksheet or Dashboard title.

Saved favorites can be visited by clicking on the dropdown next to the star icon on the top right hand corner of Tableau Server environment.

User Preferences
Changes to email account setup, subscriptions, start page, language, account password, and saved data connection passwords can be applied by clicking on the User Name on the right hand corner of Tableau Server environment, then selecting User Preferences.
Navigating a Workbook or Dashboard on Tableau Server

Tab navigation and filters

The tabs represent the various dashboards and views contained in the workbook. You can navigate them through these tabs instead of jumping back to the previous menu.

The highlighted box shows the user filters available for you to interact with and change the data displayed in the dashboard.

Workbook Options

When opening either a workbook or dashboard, there will be icons throughout the page to help you analyze the data better.
<table>
<thead>
<tr>
<th>Term</th>
<th>Button</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Share</td>
<td>Share</td>
<td>Every published view and workbook can be shared via email or embedded into another webpage, wiki, or web application. Anyone viewing a shared view must have an account on Tableau Server and permission to access the view.</td>
</tr>
<tr>
<td>Remember my changes</td>
<td>Remember my changes</td>
<td>Users looking to apply simple modification to published workbooks or views by applying a report filter can save a version of the report so that they do not have to apply the filter every time the workbook is opened.</td>
</tr>
<tr>
<td>Edit</td>
<td>Edit</td>
<td>If Edit permission is enabled on a published workbook, Publishers, Web Publishers, and Interactor users have the ability to edit the workbook to rebuild as deemed necessary. While Publisher and Web Publisher users can save a version of the edited report, Interactor users will not have the ability to save their changes anywhere on Tableau Server.</td>
</tr>
<tr>
<td>Export</td>
<td>Export Image as PNG, export summarized data (different than underlying data), export to cross-tab (summarized numbers), or export to PDF.</td>
<td></td>
</tr>
<tr>
<td>Revert All</td>
<td>Revert All</td>
<td>Reverts all modifications back to the beginning to when dashboard loaded.</td>
</tr>
<tr>
<td>Pause Automatic Updates</td>
<td>Pause Automatic Updates</td>
<td>Useful when dashboard takes a while to load. You can pause updates to use a variety of filters and then click the button again.</td>
</tr>
<tr>
<td><strong>Refresh Data for this View</strong></td>
<td>Will drop the data connection and rebuild a new one. Useful when using transactional system</td>
<td></td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------------------------------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td><strong>Subscribe</strong></td>
<td>On a regular interval, users can have a snapshot of the view automatically delivered to their email inbox without the need for logging into Tableau Server. To do this, users will have to subscribe to workbooks.</td>
<td></td>
</tr>
<tr>
<td><strong>Download</strong></td>
<td>If Download permission is enabled, Publishers can download workbooks to their local machine for further work.</td>
<td></td>
</tr>
<tr>
<td><strong>Sort</strong></td>
<td>Ability to change order of data either ascending or descending. Note: Sorting not available on map.</td>
<td></td>
</tr>
<tr>
<td><strong>Keep Only</strong></td>
<td>Keep Only members in the selection. (only if enabled and user selects a value)</td>
<td></td>
</tr>
<tr>
<td><strong>Exclude</strong></td>
<td>Exclude members in the selection. (only if enabled and user selects a value)</td>
<td></td>
</tr>
<tr>
<td><strong>View Data</strong></td>
<td>New browser will open with underlying data and ability to download locally. (only if enabled and user selects a value)</td>
<td></td>
</tr>
</tbody>
</table>

**Sharing Workbooks**

Every published view and workbook can be shared via email or embedded into a webpage, wiki, or web application. Anyone viewing a shared view must have an account on Tableau Server and permission to access the view.

Click **Share** and a popup will display with links to the view

**Saving Customized Views**

As users filter, interact and sort through views on Tableau Server, they can save a version of the report so they do not have to apply the changes every time the workbook is opened.
Click **Remember my changes** and a popup will display to view custom views or create a new one.

**Comments**

You can enter a comment at the bottom of the workbook page for everyone to see.

Type your text in the comment box and click **Save**.

**Tableau Server Workspace**

The Tableau Server workspace consists of menus, a toolbar, the Data Source window, cards that contain shelves and legends, and one or more sheets.

Worksheets contain shelves, which are where you drag data fields to build views. The illustration below highlights the various components of a Tableau workbook using the example you will create in class.
Data Connection Window

Data fields appear on the left side of the workspace in the Data window. Unlike Tableau Desktop, in Tableau Server environment, users can only leverage one Data Source at a time.

Dimensions

Once you have opened a Data Source, the Data Window will populate with the corresponding dimensions, measures, sets, parameters, or field types.

- **Dimensions** – Fields that typically hold discrete qualitative data. Examples of dimensions include dates, customer names, and customer segments.

- **Hierarchies**

  Data hierarchies are organization of data of similar fields for a specific dimension. Dimensions of hierarchies have the +/- sign in the Data window.

  You can expand or collapse the various areas or hierarchies in a multidimensional Data window by clicking the + button.

Using Hierarchies in Shelves

You can drill down or drill up by clicking on a dimension that is placed on any shelf. If the dimension is on the Rows or Columns shelf, drilling down shows more data, or headers, in the table, while drilling up shows less data in the table.

If a dimension shows the plus sign +, then its children are not already showing and you can drill down at least one level. If the dimension member shows the minus sign -, then its children are already showing and you can drill up.

**Tip:** The order that the hierarchical dimensions are placed in the columns and rows shelf indicates order of priority.

Measures

Fields that typically hold numerical data that can be aggregated. Examples of measures include sales, profit, number of employees, etc.
Sets

An additional area that stores custom fields based on existing dimensions and criteria that you specify.

Parameters

Dynamic values that can replace constant values in calculations and can serve as filters. For example, you might have a calculated field that returns True if Sales are greater than $500,000, and otherwise returns False. Using a parameter, you can replace the constant value of $500,000 in the calculated field with a parameter that you can change dynamically using the Parameter control.

Toolbar

<table>
<thead>
<tr>
<th>Term</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td></td>
<td>Undoes the last task you completed. There are unlimited undoes in Tableau.</td>
</tr>
<tr>
<td>Redo</td>
<td></td>
<td>Repeats the last task you canceled with the Undo button.</td>
</tr>
<tr>
<td>Updates On</td>
<td></td>
<td>Controls whether Tableau automatically updates the view when changes are made. Use the drop-down list to control updates on the entire sheet or just quick filters.</td>
</tr>
<tr>
<td>Totals</td>
<td></td>
<td>Provides option to show column/row grand totals, as well as subtotals.</td>
</tr>
<tr>
<td>Cell Size</td>
<td></td>
<td>Helps resize the text cell space.</td>
</tr>
<tr>
<td>Swap</td>
<td></td>
<td>Moves the fields on the Row shelf to the Column shelf and vice versa.</td>
</tr>
<tr>
<td>Export</td>
<td></td>
<td>Exports the Tableau View as an Image, PDF, Crosstab into Excel, or opens another web browser window displaying the summary and underlying data.</td>
</tr>
<tr>
<td>Show Me</td>
<td></td>
<td>Displays up to twenty-three alternate views of the data, in addition to the best view according to best practices. The options presented when this button is clicked depend on the data fields that have been selected.</td>
</tr>
</tbody>
</table>

Determine Views Available using Show Me!

Show Me! feature will display available view types based on the dimensions and measures added to the Rows and Columns shelves.
1. Drag **Region** from the Orders table dimension into the row shelf and the **Sales** measure into the column shelf.

2. Click on the **Show Me!** button on the toolbar. Based on the dimensions and measures selected in the Columns and Rows shelves, Tableau will recommend the best representation of the data. The default representation was Horizontal bars.

3. Click on **Show Me!** button again and select the various chart options that Tableau recommends:
   - Heat Map
   - Highlight Table
   - Pie Chart
   - Stacked Bar
   - Histogram
   - Scatter
   - Box-and-Whisker Plot
   - Maps
   - Tree Map
   - Word Cloud
   - Packed Bubble

**Heat Map**

A Heat Map enables easy comparison of categorical values using color ranges. It shows measures with the size and color of square marks. A typical selection is two dimensions and one measure.
Highlight Table

Shows measures with color fill behind text. Requires exactly one measure and at least two dimensions.

Pie Chart

The pie chart can be used to show proportions. A typical selection is one measure and one dimension.

Stacked Bar

A Stacked Bar is good for showing overall trend across categories or over time while comparing the trend within categories. A typical selection is one measure and two dimensions.
Histogram

A histogram shows the distribution of a single measure grouped into several bins based on the range of values. Histograms are used to show distributions of measures while bar charts are used to compare dimensions. Requires exactly one measure.

Scatter Plot

A scatter plot allows a user to investigate the relationship between multiple variables. A typical selection is 2 measures and at least 1 dimension.
Box-and-Whisker Plot

Box-and-whisker plots are typically used to demonstrate distribution of observations. They are also useful for showing outliers. It requires at least one measure.

Mapping

When you are connected to data that contains location information you can automatically show the data on a geographic map.

Tree map

Tree maps are designed to display hierarchical data as rectangles within rectangles. For each rectangle, two measures can be coded – one will affect the size of a rectangle, and the other will affect color. If a single dimension is used, all dimension members will appear in size and color-encoded together.
Word Cloud

Word Clouds could display members of a chosen dimension as text, but in varying colors and sizes, depending on one or two measures. Word Clouds are tree maps, except with Text as the chosen mark type.

Packed Bubble

Packed Bubble charts allow you to look at categorical data represented by the number of bubbles as well as the quantitative data by the size of those bubbles. Additionally, you can add colors to delineate between each of the categories.
Working with Cards and Shelves

Every worksheet contains a variety of different cards, or containers, for shelves, legends, and other controls.

The following list describes the most common cards:

- **Columns** – contains the Columns shelf where you can drag fields to add columns to the view.
- **Rows** – contains the Rows shelf where you can drag fields to add rows to the view.
- **Pages** – contains the Pages shelf where you can create several different pages with respect to the members in a dimension or the values in a measure.
- **Filters** – contains the Filters shelf; use this shelf to specify the values to include in the view.
- **Quick Filters** – a separate quick filter card is available for every field in the view. Use these cards to easily include and exclude values from the view without having to open the Filter dialog box.
- **Marks** – contains a mark selector where you can specify the mark type as well as the Path, Shape, Text, Color, Size, Angle, and Detail shelves. The availability of these shelves are dependent on the fields in the view.
- **Color Legend** – contains the legend for the color encodings in the view and is only available when there is a field on the Color shelf.
- **Shape Legend** – contains the legend for the shape encodings in the view and is only available when there is a field on the Shape shelf.

- **Size Legend** – contains the legend for the size encodings in the view and is only available when there is a field on the Size shelf.

**Rearranging Cards**

1. Point the cursor at the title area of the card you want to move. When the cursor becomes the move symbol, click and drag the card to a new position.

2. As you drag the card around the worksheet, the possible positions for it are highlighted with a black bar.

   - **Note:** The Undo button only works for the views, not for undoing reordering of cards.

**Columns and Rows Shelves**

The Columns shelf creates the columns of a table, while the Rows shelf creates the rows of a table. You can place an unlimited number of fields on these shelves.

When you place a dimension on the Rows or Columns shelf, headers for the view are created. When you place a measure on the Rows or Columns shelf, quantitative axes for that measure are created. As you build up your data view with more fields, additional headers and axes are included in the table. Using the filters based on the Rows and Columns shelves may enable you to get an increasingly detailed picture of your data.

**Types of Shelves**

Every worksheet in Tableau contains shelves. Cards are for shelves. Shelves are fields where customizations are made. By placing fields on shelves, you can create the rows and columns of a data view, exclude data from the view, show additional levels of detail, and encode the data in various ways.

Some shelves include the following:

- Columns and Rows Shelves
- Pages Shelf
- Filters Shelf
- Detail Shelf
- Color Shelf
- Size Shelf
- Shape Shelf
- Label Shelf
- Path Shelf
Note: Some shelves are available only when certain mark types are used. For example, the Shape shelf appears when the shape mark type is used.

Tip: You should experiment with various combinations of shelves, fields, and mark types to find the optimal view for your data.

Pages Shelf
The Pages shelf lets you break a view into a series of pages so you can better analyze how a specific field affects the rest of the data in a view. When you place a dimension on the Page shelf you are basically adding a new row for each member in the dimension. When you place a measure on the Pages shelf, the measure is converted into a discrete measure. The page shelf creates a view on a different page for each new row so you can easily flip through each view and compare them on a common axis. A common use for a page shelf is adding a date field to flip through time.

Filters Shelf
The Filters shelf allows you to specify which data to include and exclude. For example, you might want to analyze the profit for each customer segment, but only for certain shipping containers and delivery times. By placing fields on the Filters shelf, you can create such a view.

Tips:
- You can filter data using measures, dimensions, or both at the same time.
- The order of fields placed on the Filters shelf does not affect the data view because the filters are independent.

Detail on Marks Card
The Detail also allows you to separate the marks in a data view according to the members (levels of detail) of a dimension. However, unlike using the Rows and Columns shelf, using this shelf is a way to show more data without changing the table structure.
Tips:

- You can place any number of dimensions on the Detail shelf. In fact, placing all dimensions on this shelf is one way to display all the rows of your data source.
- Placing a measure on the Detail shelf has no effect because measures do not contain members.

Note: The Detail shelf works only if the measures that contribute axes to the table are aggregated.

Color Shelf

The Color shelf encodes data by assigning different colors to the marks in a data view based on the values of a field. The effect of color-encoding your data view depends on whether you use categorical or quantitative colors.

- **Categorical Colors** - When you add a dimension to the Color shelf a categorical legend is added based on the members in the dimension field.
- **Quantitative Colors** - When you add a measure to the Color shelf a quantitative legend is added creating a continuous range of colors.
- **Transparency** - Is especially useful in dense scatter plots or when you are looking at data overlaying a map or background image. As you slide the slider toward the left the marks become more transparent.
- **Effects** – Use effects to add borders to data points or highlight data points.

Size Shelf

The Size shelf allows you to encode data by assigning different sizes to the marks in a data view. Depending on whether you use a discrete or continuous field you will add either categorical or quantitative size encodings.
- Categorical Sizes – categorical sizes work best for ordered data like years or quarters.
- Quantitative Sizes – the smallest value is assigned the smallest sized mark while the largest value is represented by the largest mark.

**Shape Shelf**

The Shape shelf allows you to encode data by assigning different shapes to the marks in a data view. Marks are separated into different shapes according to the members of the chosen dimension.

**Note:** Custom shapes can be imported into Tableau using Tableau Desktop

**Label Shelf**

The Label shelf allows you to view the numbers associated with a data view, and to encode data by assigning text labels to the marks.

**Edit Workbooks**

Publishers, Web Publishers, and Interactor have the ability to edit published workbooks directly on Tableau Server. While Publisher and Web Publisher users can save a version of the edited report to another project or folder, Interactor users will not have the ability to save their changes anywhere on Tableau Server.
Once the Edit button is clicked, Tableau will open the edit worksheet page displaying all components that make up the views and worksheets. To edit existing work, you can drag and drop objects from the Data Connection Objects window to the Columns and Rows Shelves.

**Saving Edited Workbooks**

- To save edited workbook with the latest changes, you can click the **Save** button which will replace the originally published version.
- To save edited workbook with a new name and to a different project folder, you can click the **Save As** button which will create/save the new version to the location specified.
- **Revert** option will undo all changes.
- **Done** option will take you back to report view mode.

**Module Summary**

You should now be able to:

- Log into Tableau Server and navigate the site
- Open a workbook and interact with a dashboard on Tableau Server
- Share and save customized views on Tableau Server
- Create new workbooks on Tableau Server using Show Me
- Edit published workbooks
Module 15: Mobile Application

Module Objectives

- Log into Tableau Mobile Application and navigate the dashboards
- Open a dashboard and interact with it in the application
- Edit workbooks from within the application

Mobile Dashboard Access and Navigation

Tableau enables users to view and edit dashboards on the go through a Mobile Application. All dashboards that are accessible by a user through the Tableau Server website can be access through the application.

Users that have an Apple device can download the Tableau Mobile Application from the App Store. Users with an Android Tablet can download the App from the Google Play Store. At this time, the Tableau Mobile Application is not compatible with Android Phones.

- UCLA Health’s Tableau server is only accessible through the corporate network. Follow the standard UCLA Health instructions to access the network from a mobile device.
- Once logged into the network, open the application and select **Sign In**, which is found in the top left corner.
- Enter in the Tableau server name and click on **Connect**.
  Tableau Server Name for Training: [https://bsdtableau02](https://bsdtableau02)
  Tableau Server Name for Production: **TBD**
- On the next page, enter your UCLA Health network username and password and select **Sign In** to access the Dashboards found on Tableau Server.

Once signed into the Mobile Application, there are several navigation options in the top right corner.

- **Favorites** will display all dashboards that have the star next to them selected. This enables a user to mark the dashboards that are most important to them for easy access later.
- **Recents** will have all dashboards that a user recently viewed.
- **All** contains all dashboards that a user has permission to access.

The last two icons in the right corner allow a user to view the available dashboards as icons or as a list of dashboard names. Once a dashboard is identified, clicking on the dashboard name or icon will open it.
**Mobile Dashboard Interaction**

Dashboard interaction on the Mobile Application is similar to the interaction on Tableau Server.

**Navigating Views**
A set of tabs are available at the top of the dashboard to navigate between the Views in a Dashboard.

**Prompts**
Selecting a prompt box will open a dropdown menu that allows you to select values to filter your dashboard results.

**Geolocation**
The Mobile Application can identify a device’s location and place it on a dashboard map if the location feature is enabled on the device.

**Actions**
Some dashboards may be setup to allow you to use one visualization as a filter for subsequent visualizations. This is also enabled in the Mobile Application.

**Exports**
Selecting the arrow icon in the top middle of the interface allows you to export the dashboard as an image or PDF. Depending on the security permissions, you may have the option to export the information as a data table or cross-tab.

**Editing in Mobile Application**

A dashboard can be edited from within the Mobile Application. If a user has permission to make changes to the dashboard, an **Edit** option will be available in the top left corner of the application.

Selecting the **Edit** option will open an interface that resembles the Tableau Server Edit page and allows a user to make updates to a dashboard. Once finished, the updates can be saved using the **Save** option in the top left corner. Saved changes can be viewed from the application or Tableau server.

**Note:** Updating a dashboard from the Mobile Application will also update the same dashboard on Tableau Server.

**Module Summary**

You should now be able to:
• Log into Tableau Mobile Application
• Navigate the menus and select a dashboard
• Open workbook and interact with a dashboard in the application
• Edit workbooks from within the application
# Appendix A: Glossary

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Aggregation</strong></td>
<td>An aggregation results from a mathematical operation applied to a measure. Predefined aggregations include summation, average, and so on. Dimensions can be converted to measures by aggregating them as a count.</td>
</tr>
<tr>
<td><strong>Axis</strong></td>
<td>An axis is displayed in a table when you place a continuous field on the Rows or Column shelf. The axis labels are given by the name of the measure.</td>
</tr>
<tr>
<td><strong>Cell</strong></td>
<td>Any table you create in Tableau has the cell as its basic element. Controlling cells to enhance your data view is useful for text tables and heat maps.</td>
</tr>
<tr>
<td><strong>Color Legend</strong></td>
<td>The color legend displays the colors associated with a measure or dimension members. The default legend is modified when you place a dimension or a measure on the Color shelf.</td>
</tr>
<tr>
<td><strong>Color Shelf</strong></td>
<td>The Color shelf allows you to encode data by assigning different colors to the marks in a data view. The shelf accepts a measures or a dimension.</td>
</tr>
<tr>
<td><strong>Columns Shelf</strong></td>
<td>The Columns shelf allows you to create the columns of a data table. The shelf accepts any number of dimensions and measures. When you place a dimension on the Columns shelf, headers for the members of that dimension are created. When you place a measure on the Columns shelf, quantitative axes for that measure are created.</td>
</tr>
<tr>
<td><strong>Cross-Tab</strong></td>
<td>A cross-tab is another name for a text table. Text tables provide an easy way to display the numbers associated with dimension members.</td>
</tr>
<tr>
<td><strong>Dashboard</strong></td>
<td>A dashboard is a collection of several worksheets shown in a single location where you can compare and monitor a variety of data simultaneously. When you place a dimension on the Color shelf, Tableau separates the marks according to the members in the dimension, and assigns a unique color to each member. When you place a measure on the Color shelf, Tableau draws each mark with a different color using a continuous range. In both cases, a legend describes the color encoding.</td>
</tr>
<tr>
<td><strong>Dimensions</strong></td>
<td>Dimensions are independent fields. Dimensions typically hold discrete data such as hierarchies and members that cannot be aggregated. Examples of dimensions include dates, customer names, and customer segments.</td>
</tr>
<tr>
<td><strong>Fields</strong></td>
<td>Field is another name for a dimension or a measure. All databases contain fields. Fields contain data. For relational data sources, fields are the columns of a table. For multidimensional (OLAP) data sources, fields are the dimensions of a cube. Each dimension or column contains a unique attribute of the data such as customer name, sales, product type, and so on.</td>
</tr>
<tr>
<td><strong>Filters Shelf</strong></td>
<td>The Filters shelf allows you to exclude data from a view. You can filter data using measures, dimensions, and both measures and dimensions at the same time.</td>
</tr>
</tbody>
</table>
You can filter data based on the fields that make up the columns and rows of the table. This is called an internal filter. You can also filter data based on fields that do not compose the table. This is called an external filter.

**Global Filter**
A global filter is a filter that applies to all worksheets in the workbook that are connected to the same data source.

**Measures**
Measures are fields that are dependent variables. They are typically quantitative fields or calculated fields like sales, temperature or frequency.

**Sets**
An additional area that stores custom fields based on existing dimensions and criteria that you specify.

**Workbooks**
Workbooks hold one or more worksheets and dashboards. By saving a workbook, you can save all open sheets in one file that can then be easily shared.

**Worksheets**
Worksheets hold your data views. You can save individual worksheets as bookmarks. Each worksheet can be connected to only one data source. However, different worksheets in a workbook can be connected to different data sources.
## Appendix B: Mark Type Matrix

<table>
<thead>
<tr>
<th>Mark Type</th>
<th>When to Use</th>
<th>Tip</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bar Mark</td>
<td>The bar mark type is useful when you want to compare measures across categories, or when you want to break data down into stacked bars. The Mark menu is set to Automatic, and you place a dimension and a measure as the inner fields on the Rows and Columns shelves (or vice versa).</td>
<td>If the dimension is a date dimension, the Line mark is chosen instead.</td>
<td><img src="image" alt="Bar Mark Example" /></td>
</tr>
<tr>
<td>Square Mark</td>
<td>The square mark type is useful when you want to clearly see individual data points. When you select Square from the Mark menu, Tableau displays your data using squares.</td>
<td>By placing a measure on the Color shelf, square marks can be used to create a heat map.</td>
<td><img src="image" alt="Square Mark Example" /></td>
</tr>
<tr>
<td>Scatter Plot / Shape Mark</td>
<td>The shape mark type is useful when you want to clearly see individual data points while also viewing categories associated with those points. By default, the shape used is an open circle. You can enhance your visual by placing a dimension on the Shape shelf.</td>
<td>Tableau separates the marks according to the members in the dimension, and assigns a unique shape to each member.</td>
<td><img src="image" alt="Scatter Plot Example" /></td>
</tr>
<tr>
<td>Line Mark</td>
<td>The line mark type is useful when you want to see trends in data over time.</td>
<td>NA</td>
<td><img src="image" alt="Line Mark Example" /></td>
</tr>
<tr>
<td>Area Mark</td>
<td>The Area mark type is useful when you have a view the marks are Stacked and do not overlap.</td>
<td>This type of chart is best to show the total values so you can get and idea of how a dimension is contributing to an overall trend.</td>
<td><img src="image" alt="Area Mark Example" /></td>
</tr>
<tr>
<td>Gantt Bar Mark</td>
<td>The Gantt bar mark type is useful when you want to view dates, project plans, or the relationships between different quantitative variables.</td>
<td>You can enhance your visual by placing a measure on the Size shelf and dimension on a color.</td>
<td><img src="image" alt="Gantt Bar Mark Example" /></td>
</tr>
<tr>
<td>Mark Type</td>
<td>Description</td>
<td>Use</td>
<td></td>
</tr>
<tr>
<td>---------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>Pie Mark</td>
<td>The pie mark can be used to show proportions or percentage of a whole.</td>
<td>Use the map feature to enhance your visual.</td>
<td></td>
</tr>
<tr>
<td>Filled Map Mark</td>
<td>The filled map mark type uses geocoding to fill a polygon with a color based on data.</td>
<td>Use when you are plotting two measures against each other.</td>
<td></td>
</tr>
<tr>
<td>Stacking Mark</td>
<td>Stacking marks is relevant when your data view includes numeric axes. When marks are stacked, they are drawn cumulatively along an axis. When marks are not stacked, they are drawn independently along an axis.</td>
<td>NA</td>
<td></td>
</tr>
</tbody>
</table>
## Appendix C: Keyboard Shortcuts

- **Ctrl+A**: Select all data
- **Ctrl+B**: Smaller table
- **Ctrl+Shift+B**: Larger table
- **Ctrl+C**: Copy selected data
- **Ctrl+Alt+C**: Place selected field on columns shelf
- **Ctrl+D**: Connect to data source
- **Ctrl+E**: Describe Sheet
- **Ctrl+F**: Find Command
- **Ctrl+Alt+F**: Place selected field on filters shelf
- **Ctrl+H**: Switch in and out of Presentation Mode
- **Ctrl+Alt+I**: Place selected field on size shelf
- **Ctrl+L**: Flip orientation of column labels
- **Ctrl+Alt+L**: Place selected field on detail shelf
- **Ctrl+M**: New Worksheet
- **Ctrl+N**: New Workbook
- **Ctrl+O**: Open file
- **Ctrl+Alt+O**: Place selected field on color shelf
- **Ctrl+P**: Print
- **Ctrl+Alt+P**: Place selected field on pages shelf
- **Ctrl+Alt+R**: Place selected field on rows shelf
- **Ctrl+S**: Save file
- **Ctrl+Alt+S**: Place selected field on shape shelf
- **Ctrl+Alt+T**: Place selected field on text shelf
- **Ctrl+V**: Paste clipboard
- **Ctrl+Y**: Redo
- **Ctrl+Alt+Y**: Place selected field on columns shelf
- **Ctrl+Z**: Undo
- **Ctrl+Alt+delete**: Clear the current worksheet
- **Ctrl+(left arrow)**: Make rows narrower
- **Ctrl+(right arrow)**: Make rows wider
- **Ctrl+(down arrow)**: Make columns shorter
<table>
<thead>
<tr>
<th>Keyboard Combination</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+(up arrow)</td>
<td>Make columns taller</td>
</tr>
<tr>
<td>Ctrl + SHIFT + B</td>
<td>Makes table bigger</td>
</tr>
<tr>
<td>Ctrl + B</td>
<td>Makes table smaller</td>
</tr>
<tr>
<td>Ctrl+1</td>
<td>Show Me!</td>
</tr>
<tr>
<td>F1</td>
<td>Opens the Help</td>
</tr>
<tr>
<td>F4</td>
<td>Starts and stops forward playback</td>
</tr>
<tr>
<td>SHIFT+F4</td>
<td>Starts and stops backward playback</td>
</tr>
<tr>
<td>Ctrl+F4</td>
<td>Deletes the current worksheet or hides the worksheet if it is used in a dashboard.</td>
</tr>
<tr>
<td>F5</td>
<td>Refreshes the data source</td>
</tr>
<tr>
<td>F9</td>
<td>Run Query</td>
</tr>
<tr>
<td>F12</td>
<td>Reverts workbook to last saved state.</td>
</tr>
<tr>
<td>Ctrl + .</td>
<td>Skip forward one page</td>
</tr>
<tr>
<td>Ctrl + ,</td>
<td>Skip backward one page</td>
</tr>
</tbody>
</table>
## Appendix D: Functions Definitions

### Number Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>ABS(number)</code></td>
<td>Returns the absolute value of the given number.</td>
<td>▪ ABS(-7) = 7</td>
</tr>
<tr>
<td></td>
<td></td>
<td>▪ ABS([Budget Variance]) returns the absolute value for all the numbers</td>
</tr>
<tr>
<td></td>
<td></td>
<td>contained in the Budget Variance field.</td>
</tr>
<tr>
<td><code>MAX(number, number)</code></td>
<td>Returns the maximum of the two arguments, which must be of the same type. Returns Null if either argument is Null. MAX can also be applied to a single field in an aggregate calculation.</td>
<td>▪ MAX(4,7) MAX(Sales,Profit)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>▪ MAX([First Name],[Last Name])</td>
</tr>
<tr>
<td><code>MIN(number, number)</code></td>
<td>Returns the minimum of the two arguments, which must be of the same type. Returns Null if either argument is Null. MIN can also be applied to a single field in an aggregate calculation.</td>
<td>▪ MIN(4,7) MIN(Sales,Profit)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>▪ MIN([First Name],[Last Name])</td>
</tr>
</tbody>
</table>

### String Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>Contains(string, substring)</code></td>
<td>Returns true if the given string contains the specified substring.</td>
<td>CONTAINS(“Calculation”, “alcu”) = true</td>
</tr>
<tr>
<td><code>ENDSWITH(string, substring)</code></td>
<td>Returns true if the given string ends with the specified substring. Trailing white spaces are ignored.</td>
<td>ENDSWITH(“Tableau”, “leau”) = true</td>
</tr>
<tr>
<td><code>LEFT(string, number)</code></td>
<td>Returns the left-most number of characters in the string.</td>
<td>LEFT(“Matador”, 4) = “Mata”</td>
</tr>
<tr>
<td><code>MAX(a, b)</code></td>
<td>Usually applied to numbers, but also works on strings. Returns the maximum of a and b (a and b must be of the same type). With strings, MAX finds the value that is highest in the sort sequence defined by the database for that</td>
<td>MAX (“Apple”, “Banana”) = “Banana”</td>
</tr>
<tr>
<td>Function</td>
<td>Description</td>
<td>Example</td>
</tr>
<tr>
<td>-----------------------</td>
<td>---------------------------------------------------------------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td><code>STARTSWITH(string, substring)</code></td>
<td>Returns true if the given string starts with the specified substring. Leading white spaces are ignored.</td>
<td><code>STARTSWITH(&quot;Joker&quot;, &quot;Jo&quot;) = true</code></td>
</tr>
<tr>
<td><code>UPPER(string)</code></td>
<td>Returns the lower case version of the string.</td>
<td><code>UPPER(&quot;Calculation&quot;) = “CALCULATION”</code></td>
</tr>
</tbody>
</table>
## Appendix E: Operators

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>+ (addition)</td>
<td>This means addition when applied to numbers and concatenation when applied to strings. When applied to dates, it can be used to add a number of days to a date.</td>
<td>7+3, Profit + Sales, ‘abc’ + ‘def’ = ‘abcdef’, #April 15, 2004# + 15 = #April 30, 2004#</td>
</tr>
<tr>
<td>− (subtraction)</td>
<td>This means subtraction when applied to numbers and negation if applied to an expression. When applied to dates, it can be used to subtract a number of days from a date. Hence it can also be used to calculate the difference in days between two dates.</td>
<td>7-3, Profit - Sales, -(7+3) = -10, #April 16, 2004# - 15 = #April 1, 2004#, #April 15, 2004# - #April 8, 2004# = 7</td>
</tr>
<tr>
<td>* (multiplication)</td>
<td>This means numeric multiplication.</td>
<td>5 * 4 = 20.</td>
</tr>
<tr>
<td>/ (division)</td>
<td>This means numeric division.</td>
<td>20 / 4 = 5.</td>
</tr>
<tr>
<td>% (modulo)</td>
<td>This calculates a numeric remainder.</td>
<td>5 % 4 = 1</td>
</tr>
<tr>
<td>= =, =, &gt;, &lt;, &gt;=, &lt;=, !=, &lt;&gt; (comparisons)</td>
<td>Each operator compares two numbers, dates, or strings and returns a boolean (TRUE or FALSE).</td>
<td>= = or =(equal to), &gt; greater than), &lt; (less than), &gt;= (greater than or equal to), &lt;= (less than or equal to), != and &lt;&gt; (not equal to)</td>
</tr>
<tr>
<td>^ (power)</td>
<td>This symbol is equivalent to the POWER function. It raises a number to the specified power.</td>
<td>6^3 = 216</td>
</tr>
<tr>
<td>Operator</td>
<td>Description</td>
<td>Examples</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
<td>----------</td>
</tr>
<tr>
<td>AND</td>
<td>This is a logical operator. An expression or a boolean must appear on either side of it.</td>
<td>▪ IIF(Profit =100 AND Sales =1000, “High”, “Low”)</td>
</tr>
<tr>
<td>OR</td>
<td>This is a logical operator. An expression or a boolean must appear on either side of it.</td>
<td>▪ IIF(Profit =100 OR Sales =1000, “High”, “Low”)</td>
</tr>
<tr>
<td>NOT</td>
<td>This is a logical operator. It can be used to negate another boolean or an expression.</td>
<td>▪ IIF(NOT(Sales = =Profit),”Not Equal”,“Equal”)</td>
</tr>
</tbody>
</table>
Appendix F: Tableau References

Tableau Quick Start Guides: http://www.tableau.com/support/manuals/quickstart
Tableau Training and Tutorials: http://www.tableau.com/learn/training
Tableau Knowledge Base: http://kb.tableau.com/?lang=en-us